Bug 995003 - 'Vm' object has no attribute 'addVmToMonitoredDomains'
'Vm' object has no attribute 'addVmToMonitoredDomains'
Status: CLOSED ERRATA
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: vdsm (Show other bugs)
3.3.0
Unspecified Unspecified
unspecified Severity unspecified
: ---
: 3.3.0
Assigned To: Yeela Kaplan
Katarzyna Jachim
storage
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-08 07:51 EDT by Katarzyna Jachim
Modified: 2016-02-10 12:11 EST (History)
10 users (show)

See Also:
Fixed In Version: is12
Doc Type: Bug Fix
Doc Text:
Trying to hot unplug a disk from a virtual machine failed with the error "'Vm' object has no attribute 'addVmToMonitoredDomains'". This is fixed by maintaining a list of the virtual machine's domains inside the virtual machine object, so hot unplugging a disk now works as expected.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-21 11:30:42 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Storage
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
vdsm log (7.97 MB, text/x-log)
2013-08-08 07:51 EDT, Katarzyna Jachim
no flags Details

  None (edit)
Description Katarzyna Jachim 2013-08-08 07:51:15 EDT
Created attachment 784321 [details]
vdsm log

Description of problem:
Hotplug of a disk fails with the following error:

Thread-520::ERROR::2013-08-08 10:54:18,006::BindingXMLRPC::993::vds::(wrapper) unexpected error
Traceback (most recent call last):
  File "/usr/share/vdsm/BindingXMLRPC.py", line 979, in wrapper
    res = f(*args, **kwargs)
  File "/usr/share/vdsm/BindingXMLRPC.py", line 268, in vmHotplugDisk
    return vm.hotplugDisk(params)
  File "/usr/share/vdsm/API.py", line 431, in hotplugDisk
    return curVm.hotplugDisk(params)
  File "/usr/share/vdsm/vm.py", line 3263, in hotplugDisk
    self.addVmToMonitoredDomains(self.id, diskParams['domainID'])
AttributeError: 'Vm' object has no attribute 'addVmToMonitoredDomains'

Version-Release number of selected component (if applicable): is9, vdsm-4.12.0-37.gitfd6a1b7.el6ev.x86_64

How reproducible: 100%
http://jenkins.qa.lab.tlv.redhat.com:8080/view/Storage/view/3.3/job/3.3-storage_hotplug_disk_hooks-iscsi-rest/45/

Steps to Reproduce:
1. try to hotplug a disk

Actual results: action fails

Expected results: action should succeed


Additional info:
Comment 1 Katarzyna Jachim 2013-08-08 09:21:53 EDT
[root@puma17 ~]# grep -r ToMonitoredDomains /usr/share/vdsm
/usr/share/vdsm/clientIF.py:    def addVmToMonitoredDomains(self, vmId, domains):
/usr/share/vdsm/vm.py:            self.cif.addVmToMonitoredDomains(self.id, domains)
/usr/share/vdsm/vm.py:                self.addVmToMonitoredDomains(self.id, diskParams['domainID'])

so probably it should be self.cif.addVmToMonitoredDomains(self.id, [diskParams['domainID']])
Comment 2 Allon Mureinik 2013-08-14 02:39:06 EDT
Seems to be a result of commit 87e61a0c57c1275f9cab3e523e02e51ed31c941f.
Yeela, please take a look?
Comment 3 Yeela Kaplan 2013-08-14 04:50:51 EDT
Actually, this was already fixed by 87e61a0c57c1275f9cab3e523e02e51ed31c941f.

Therefore, no longer relevant.
Comment 4 Allon Mureinik 2013-08-14 10:38:56 EDT
Moving to MODIFIED so QA have the chance to verify this when a build is released.
Comment 6 Charlie 2013-11-27 19:28:11 EST
This bug is currently attached to errata RHBA-2013:15291. If this change is not to be documented in the text for this errata please either remove it from the errata, set the requires_doc_text flag to 
minus (-), or leave a "Doc Text" value of "--no tech note required" if you do not have permission to alter the flag.

Otherwise to aid in the development of relevant and accurate release documentation, please fill out the "Doc Text" field above with these four (4) pieces of information:

* Cause: What actions or circumstances cause this bug to present.
* Consequence: What happens when the bug presents.
* Fix: What was done to fix the bug.
* Result: What now happens when the actions or circumstances above occur. (NB: this is not the same as 'the bug doesn't present anymore')

Once filled out, please set the "Doc Type" field to the appropriate value for the type of change made and submit your edits to the bug.

For further details on the Cause, Consequence, Fix, Result format please refer to:

https://bugzilla.redhat.com/page.cgi?id=fields.html#cf_release_notes 

Thanks in advance.
Comment 7 errata-xmlrpc 2014-01-21 11:30:42 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-0040.html

Note You need to log in before you can comment on or make changes to this bug.