Bug 995004 - maxconn set to 2 for local gear
maxconn set to 2 for local gear
Status: CLOSED ERRATA
Product: OpenShift Container Platform
Classification: Red Hat
Component: Containers (Show other bugs)
1.2.0
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Brenton Leanhardt
libra bugs
:
: 995061 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-08 07:55 EDT by Jim Minter
Modified: 2017-03-08 12 EST (History)
5 users (show)

See Also:
Fixed In Version: openshift-origin-cartridge-haproxy-0.4.11-1.el6op.noarch
Doc Type: Bug Fix
Doc Text:
The gear running HAProxy was limited to two connections, causing unexpected load distribution. This limitation has been removed in all new gears in the current release of OpenShift Enterprise. However, this fix will not be migrated to existing gears, so users must manually modify the haproxy/conf/haproxy.cfg file to implement this fix in their current gears.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-05 09:24:07 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jim Minter 2013-08-08 07:55:16 EDT
The following commit in Origin appears to resolve the fact that with scaling gears the local gear only gets up to two connections.

https://github.com/openshift/origin-server/commit/5240cd5c6bafbd563aee2e2a078f9262e1e4d8f4

Is it feasible and appropriate for this to get into OSE 1.2?  The current functionality seems a bit odd.
Comment 2 Brenton Leanhardt 2013-08-08 09:40:52 EDT
*** Bug 995061 has been marked as a duplicate of this bug. ***
Comment 4 Gaoyun Pei 2013-08-13 03:49:47 EDT
Checked the code on puddle 1.2/2013-08-12.3.
All the code was merged in, so move this bug to VERIFIED.
Comment 7 errata-xmlrpc 2013-09-05 09:24:07 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1211.html

Note You need to log in before you can comment on or make changes to this bug.