Bug 995010 - cannot install balloon driver
cannot install balloon driver
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: virtio-win (Show other bugs)
6.5
Unspecified Unspecified
medium Severity medium
: rc
: ---
Assigned To: Vadim Rozenfeld
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-08 08:00 EDT by Chao Yang
Modified: 2013-08-09 01:15 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-09 01:15:02 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chao Yang 2013-08-08 08:00:12 EDT
Description of problem:
Cannot install balloon driver.
Other devices -> Unknown device -> Update Driver Software -> Browse my computer for driver software -> "Windows was unable to install your Unknow Device" "Windows could not find drivers software for your device"

Version-Release number of selected component (if applicable):
virtio-win-prewhql-0.1-66
qemu-kvm-0.12.1.2-2.382.el6.x86_64

How reproducible:
100%

Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
CLI:
/usr/libexec/qemu-kvm -name test -M rhel6.5.0 -cpu host -enable-kvm -m 2048 -smp 2,sockets=4,cores=2,threads=1,maxcpus=8 -rtc base=localtime,clock=host,driftfix=slew -device piix3-usb-uhci,id=usb,bus=pci.0,addr=0x1.0x2 -device virtio-serial-pci,id=virtio-serial0,max_ports=16,bus=pci.0 -chardev socket,id=channel0,path=/tmp/socket,server,nowait -device virtserialport,bus=virtio-serial0.0,nr=1,chardev=channel0,name=port0 -device virtio-scsi-pci,id=scsi -drive file=/home/win2012.qcow2,if=none,id=drive-virtio-disk0,format=qcow2,cache=none,werror=stop,rerror=stop,aio=native -device scsi-disk,bus=scsi.0,drive=drive-virtio-disk0,id=virtio-disk0,bootindex=1,lun=0 -drive file=/home/ide.qcow2,if=none,id=ide,format=qcow2,cache=none,werror=stop,rerror=stop,aio=native -device ide-drive,drive=ide,bus=ide.1,unit=1 -drive file=/home/virtio-disk.qcow2,if=none,id=drive-virtio-0-0,media=disk,format=qcow2,cache=none -device virtio-blk-pci,drive=drive-virtio-0-0,id=virt0-0-0 -netdev tap,id=hostnet1 -device e1000,netdev=hostnet1,id=net1,mac=00:1a:4a:42:48:12,bus=pci.0 -netdev tap,id=hostnet0,vhost=on -device virtio-net-pci,netdev=hostnet0,id=net0,mac=00:1a:4a:42:48:ab,bus=pci.0,bootindex=3 -spice port=5900,disable-ticketing,seamless-migration=on -k en-us -vga qxl -global qxl-vga.ram_size=67108864 -global qxl-vga.vram_size=33554432 -device intel-hda,id=sound0,bus=pci.0 -device hda-duplex,id=sound0-codec0,bus=sound0.0,cad=0 -device virtio-balloon-pci,id=balloon0,bus=pci.0 -monitor stdio -serial unix:/tmp/serial,server,nowait -global PIIX4_PM.disable_s3=0 -global PIIX4_PM.disable_s4=0 -cdrom en_windows_server_2012_x64_dvd_915478.iso -boot menu=on
Comment 2 Vadim Rozenfeld 2013-08-08 08:42:31 EDT
Can you try installing with devcon?
Windows has a default driver for memory
controller devices. You cannot install 
non MS-signed driver this way. 
In any case, if devcon doesn't work,
please upload setupapi.dev.log file.

Thanks,
Vadim.
Comment 3 Chao Yang 2013-08-09 01:15:02 EDT
(In reply to Vadim Rozenfeld from comment #2)
> Can you try installing with devcon?
> Windows has a default driver for memory
> controller devices. You cannot install 
> non MS-signed driver this way. 
> In any case, if devcon doesn't work,
> please upload setupapi.dev.log file.
> 
Hi, 
 This 'Unknown device' is actually pvpanic, there is a bug opened to make it invisible in windows. 
Bug 991100 - pvpanic device appears as an unrecognized device in Windows's Device Manager
 And I can install balloon driver to drive the correct device to work. 

 So, this issue is not a bug. Sorry for the noise.

Note You need to log in before you can comment on or make changes to this bug.