Bug 995020 - DTGov is included in ER1 Aug 12 update, but DTGov testing is blocked - http://localhost:8080/dtgov-ui - returns 404 error
DTGov is included in ER1 Aug 12 update, but DTGov testing is blocked - http:/...
Status: CLOSED CURRENTRELEASE
Product: JBoss Fuse Service Works 6
Classification: JBoss
Component: DT Governance (Show other bugs)
6.0.0 GA
Unspecified Unspecified
unspecified Severity urgent
: ER1
: ---
Assigned To: Julian Coleman
Jiri Sedlacek
: TestBlocker
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-08 08:17 EDT by Len DiMaggio
Modified: 2015-08-02 19:44 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-02-06 10:25:14 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Len DiMaggio 2013-08-08 08:17:44 EDT
Description of problem:

DTGov was not included in the ER1 build.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 1 Len DiMaggio 2013-08-14 09:16:20 EDT
Is this caused by the same deployment bug seen in:  https://bugzilla.redhat.com/show_bug.cgi?id=993272  ?
Comment 2 Len DiMaggio 2013-08-14 09:33:59 EDT
The wars are installed - but the page is not found:
09:26:33,030 INFO  [org.jboss.as.server] (ServerService Thread Pool -- 27) JBAS018559: Deployed "overlord-commons-idp.war" (runtime-name : "overlord-commons-idp.war")
09:26:33,032 INFO  [org.jboss.as.server] (ServerService Thread Pool -- 27) JBAS018559: Deployed "switchyard-bpel-console-server.war" (runtime-name : "switchyard-bpel-console-server.war")
09:26:33,032 INFO  [org.jboss.as.server] (ServerService Thread Pool -- 27) JBAS018559: Deployed "dtgov-ui-war.war" (runtime-name : "dtgov-ui-war.war")
09:26:33,033 INFO  [org.jboss.as.server] (ServerService Thread Pool -- 27) JBAS018559: Deployed "s-ramp-ui.war" (runtime-name : "s-ramp-ui.war")
09:26:33,034 INFO  [org.jboss.as.server] (ServerService Thread Pool -- 27) JBAS018559: Deployed "s-ramp-server.war" (runtime-name : "s-ramp-server.war")
09:26:33,034 INFO  [org.jboss.as.server] (ServerService Thread Pool -- 27) JBAS018559: Deployed "switchyard-bpel-console.war" (runtime-name : "switchyard-bpel-console.war")
09:26:33,034 INFO  [org.jboss.as.server] (ServerService Thread Pool -- 27) JBAS018559: Deployed "overlord-rtgov-acs.war" (runtime-name : "overlord-rtgov-acs.war")
09:26:33,035 INFO  [org.jboss.as.server] (ServerService Thread Pool -- 27) JBAS018559: Deployed "overlord-rtgov.war" (runtime-name : "overlord-rtgov.war")
09:26:33,035 INFO  [org.jboss.as.server] (ServerService Thread Pool -- 27) JBAS018559: Deployed "gadget-web.war" (runtime-name : "gadget-web.war")
09:26:33,036 INFO  [org.jboss.as.server] (ServerService Thread Pool -- 27) JBAS018559: Deployed "overlord-rtgov-epn.war" (runtime-name : "overlord-rtgov-epn.war")
09:26:33,036 INFO  [org.jboss.as.server] (ServerService Thread Pool -- 27) JBAS018559: Deployed "gadgets.war" (runtime-name : "gadgets.war")
09:26:33,037 INFO  [org.jboss.as.server] (ServerService Thread Pool -- 27) JBAS018559: Deployed "dtgov-war.war" (runtime-name : "dtgov-war.war")
Comment 3 Gary Brown 2013-08-14 10:47:00 EDT
Unpacked the sramp ER1 zip on top of EAP 6.1. Started with the standalone.xml configuration.

When I examined the deployments folder I noticed that the dtgov-ui.war had been unpacked into a folder called "dtgov-ui-war.war". I assume this is an error.

However also got the following error:

15:41:38,768 INFO  [org.jboss.as.controller] (Controller Boot Thread) JBAS014774: Service status report
JBAS014775:    New missing/unsatisfied dependencies:
      service jboss.naming.context.java.jboss.resources.ErraiService (missing) dependents: [service jboss.naming.context.java.module.dtgov-ui-war.dtgov-ui-war.env.ErraiService] 


Have cc'd Eric, to advise on whether there is a missing dependency in the zip.
Comment 4 Eric Wittmann 2013-08-14 11:15:24 EDT
The dtgov-ui 404 is because the wrong UI WAR is being included in the .zip.  There are two UI war projects at the moment:

dtgov-ui-war
dtgov-ui-war-jboss7

The latter is an overlay on top of the former, and adds JBoss 7/EAP specific configuration files.

It seems that the former is being included in the product zip rather than the latter.
Comment 5 George Varsamis 2013-08-14 12:08:01 EDT
I have changed the SRAMP assembly to unpack the war to dtgov-ui.war and have now included the correct WAR (jboss7) as per Eric's comments. Len do you want me to respin ER1 again with these fixes in ?
Comment 6 Len DiMaggio 2013-08-14 14:58:33 EDT
Hey George - YES - respin as soon as you can! Thanks!
Comment 7 Len DiMaggio 2013-08-15 13:40:39 EDT
Verified in the Aug 15 ER1 respin.

Note You need to log in before you can comment on or make changes to this bug.