Bug 995037 - Clicking on next with no password for admin entered throws NPE
Clicking on next with no password for admin entered throws NPE
Status: CLOSED CURRENTRELEASE
Product: JBoss Fuse Service Works 6
Classification: JBoss
Component: Installer (Show other bugs)
6.0.0 GA
Unspecified Unspecified
unspecified Severity high
: ER2
: ---
Assigned To: Francisco Canas
Len DiMaggio
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-08 08:48 EDT by Jiri Sedlacek
Modified: 2015-08-02 19:44 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jiri Sedlacek 2013-08-08 08:48:33 EDT
After selecting install path I click next, then I should enter admin password. If I 
 - don't enter any or 
 - enter just one line or 
 - enter non valid password or
 - enter confirm password is different 

exception is thrown:

java.lang.NullPointerException
	at com.redhat.installer.action.PasswordHelper.executeAction(PasswordHelper.java:19)
	at com.izforge.izpack.installer.IzPanel.executePostValidationActions(IzPanel.java:1409)
	at com.izforge.izpack.installer.InstallerFrame.navigateNext(InstallerFrame.java:1651)
	at com.izforge.izpack.installer.InstallerFrame.navigateNext(InstallerFrame.java:1635)
	at com.izforge.izpack.installer.InstallerFrame$NavigationHandler.navigate(InstallerFrame.java:1798)
	at com.izforge.izpack.installer.InstallerFrame$NavigationHandler.access$100(InstallerFrame.java:1765)
	at com.izforge.izpack.installer.InstallerFrame$NavigationHandler$1.run(InstallerFrame.java:1782)
	at java.lang.Thread.run(Thread.java:722)
Comment 1 Francisco Canas 2013-08-08 10:36:23 EDT
The NPE above is now handled properly, and no stack trace is printed to console. Furthermore, password validation still works as intended.

See this commit for details:
http://git.app.eng.bos.redhat.com/?p=jbossas-installer.git;a=commit;h=267dd2b68dd6768ad2c0e9ad6fa7954e3d296f6d
Comment 2 Jiri Sedlacek 2013-09-16 15:16:19 EDT
verified in ER2

Note You need to log in before you can comment on or make changes to this bug.