Bug 995061 - Scaled up app local gear has maxconn set to 2
Scaled up app local gear has maxconn set to 2
Status: CLOSED DUPLICATE of bug 995004
Product: OpenShift Container Platform
Classification: Red Hat
Component: Containers (Show other bugs)
1.2.0
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Brenton Leanhardt
libra bugs
:
Depends On: 988911
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-08 09:34 EDT by Brenton Leanhardt
Modified: 2013-08-08 09:40 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 988911
Environment:
Last Closed: 2013-08-08 09:40:51 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Brenton Leanhardt 2013-08-08 09:34:55 EDT
+++ This bug was initially created as a clone of Bug #988911 +++

Description of problem:
maconn is set to 2 for a scaled app's local gear.


Version-Release number of selected component (if applicable):


How reproducible:
Always


Expected results:
It shouldn't be limited to 2

--- Additional comment from Mrunal Patel on 2013-07-29 14:30:42 EDT ---

https://github.com/openshift/origin-server/pull/3203

--- Additional comment from Meng Bo on 2013-07-30 02:18:40 EDT ---

	        Sessions				
        	Cur	Max	Limit	Total	LbTot
  Frontend	30	60	128	16294	
    filler	0	0	0	0	0
local-gear	30	30	0	16294	16294
   Backend	30	30	128	16294	16294


Checked on devenv_3580, 
benchmark the scalable app with 30 concurrency level, check the max connection from haproxy-status page. 

The maxconn up to 30.

Move to verified.
Comment 1 Brenton Leanhardt 2013-08-08 09:40:51 EDT
Sorry for the spam.  I thought there was a way to merge this with Bug #995004 but I'm no longer seeing the option.

*** This bug has been marked as a duplicate of bug 995004 ***

Note You need to log in before you can comment on or make changes to this bug.