Bug 995095 - Titles that are ulinks are incorrectly positioned
Titles that are ulinks are incorrectly positioned
Status: CLOSED CURRENTRELEASE
Product: Publican
Classification: Community
Component: publican (Show other bugs)
future
Unspecified Unspecified
urgent Severity medium
: 3.2
: ---
Assigned To: Jeff Fearn
tools-bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-08 10:21 EDT by Martin Prpič
Modified: 2013-09-04 02:20 EDT (History)
7 users (show)

See Also:
Fixed In Version: 3.2.1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-04 02:20:49 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Updated Ulink titles (20.70 KB, image/png)
2013-08-19 02:04 EDT, Misha H. Ali
no flags Details
Local installation screenshot (12.76 KB, image/png)
2013-08-19 20:46 EDT, Misha H. Ali
no flags Details

  None (edit)
Description Martin Prpič 2013-08-08 10:21:46 EDT
Document URL: https://access.redhat.com/site/documentation/en-US/Red_Hat_Enterprise_Linux/6/html/6.3_Technical_Notes/cifs-utils.html

Section Number and Name: Any section where a title is also a ulink

Describe the issue: Section titles (and I'm guessing any other title) that are ulink at the same time are incorrectly positioned.

Suggestions for improvement: Modify the following rule, which looks to be the cause of this bug:

.title a {
  position: relative !important;
  top: -32px !important;
}
Comment 1 Katie Miller 2013-08-14 18:35:44 EDT
It appears this CSS was introduced as part of a Publican commit to address another bug, https://bugzilla.redhat.com/show_bug.cgi?id=953716. The fix should probably be made in Publican.
Comment 2 Ruediger Landmann 2013-08-15 19:49:56 EDT
(In reply to Katie Miller from comment #1)
> The fix
> should probably be made in Publican.

Agreed; it shows in our devel site too; moving bug there.
Comment 4 HSS Product Manager 2013-08-15 23:47:51 EDT
HSS-QE has reviewed and declined this request. QE for this bug will be handled by IED.
Comment 5 Jeff Fearn 2013-08-16 00:49:59 EDT
Limited rule to first-child.

To ssh://git.fedorahosted.org/git/publican.git
   7ab41ab..42f4d93  HEAD -> devel
Comment 6 Misha H. Ali 2013-08-19 02:04:44 EDT
Created attachment 787905 [details]
Updated Ulink titles

This is how ulink titles now appear on the docs-devel stage.
Comment 7 Misha H. Ali 2013-08-19 02:05:57 EDT
Tested on publican-3.2.0-3.fc19.t5.noarch on Fedora 19

The ulink title now hovers higher the "Chapter X" (see screenshot in comment #6) so setting this back to assigned.
Comment 8 Ruediger Landmann 2013-08-19 02:40:42 EDT
Misha -- can you please try packaging this and installing locally? so:

publican package --binary --lang en-US

sudo yum localinstall <name of -web- rpm>

and check the output?
Comment 9 Misha H. Ali 2013-08-19 20:46:48 EDT
Created attachment 788237 [details]
Local installation screenshot

Checked in local installation according to instructions. Looks correct now (see screenshot).

Note You need to log in before you can comment on or make changes to this bug.