Bug 995303 - TypeError: nothing connected to <bound method SourceSpoke.on_repoMirrorlistCheckbox_toggled of <pyanaconda.ui.gui.spokes.source.SourceSpoke object at 0x7fb447eff410>>
TypeError: nothing connected to <bound method SourceSpoke.on_repoMirrorlistCh...
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
19
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Chris Lumens
Fedora Extras Quality Assurance
abrt_hash:3e514bfb720d0b55a5b795ce6c4...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-08 22:34 EDT by Jason Scalia
Modified: 2013-09-09 14:33 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-09 14:33:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: anaconda-tb (349.39 KB, text/plain)
2013-08-08 22:34 EDT, Jason Scalia
no flags Details
File: anaconda.log (7.89 KB, text/plain)
2013-08-08 22:35 EDT, Jason Scalia
no flags Details
File: environ (441 bytes, text/plain)
2013-08-08 22:35 EDT, Jason Scalia
no flags Details
File: lsblk_output (1.38 KB, text/plain)
2013-08-08 22:35 EDT, Jason Scalia
no flags Details
File: nmcli_dev_list (11.81 KB, text/plain)
2013-08-08 22:35 EDT, Jason Scalia
no flags Details
File: os_info (179 bytes, text/plain)
2013-08-08 22:35 EDT, Jason Scalia
no flags Details
File: program.log (35.40 KB, text/plain)
2013-08-08 22:35 EDT, Jason Scalia
no flags Details
File: storage.log (56.86 KB, text/plain)
2013-08-08 22:35 EDT, Jason Scalia
no flags Details
File: syslog (115.27 KB, text/plain)
2013-08-08 22:35 EDT, Jason Scalia
no flags Details
File: ifcfg.log (830 bytes, text/plain)
2013-08-08 22:35 EDT, Jason Scalia
no flags Details
File: packaging.log (4.50 KB, text/plain)
2013-08-08 22:35 EDT, Jason Scalia
no flags Details

  None (edit)
Description Jason Scalia 2013-08-08 22:34:54 EDT
Description of problem:
Set NFS as the installation source and only placed an IP with no other paths/arguments. Returned to the main menu, then clicked Installation source

Version-Release number of selected component:
anaconda-19.30.13-1

The following was filed automatically by anaconda:
anaconda 19.30.13-1 exception report
Traceback (most recent call first):
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/source.py", line 888, in _clear_repo_info
    self._repoMirrorlistCheckbox.handler_block_by_func(self.on_repoMirrorlistCheckbox_toggled)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/source.py", line 861, in _reset_repoStore
    self._clear_repo_info()
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/source.py", line 685, in refresh
    self._reset_repoStore()
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/hubs/__init__.py", line 109, in _runSpoke
    action.refresh()
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/hubs/__init__.py", line 403, in _on_spoke_clicked
    self._runSpoke(spoke)
TypeError: nothing connected to <bound method SourceSpoke.on_repoMirrorlistCheckbox_toggled of <pyanaconda.ui.gui.spokes.source.SourceSpoke object at 0x7fb447eff410>>

Additional info:
cmdline:        /usr/bin/python  /sbin/anaconda
cmdline_file:   initrd=initrd.img inst.stage2=hd:LABEL=LIVE quiet BOOT_IMAGE=vmlinuz 
executable:     /sbin/anaconda
hashmarkername: anaconda
kernel:         3.9.5-301.fc19.x86_64
product:        Fedora
release:        Cannot get release name.
type:           anaconda
version:        19
Comment 1 Jason Scalia 2013-08-08 22:34:59 EDT
Created attachment 784688 [details]
File: anaconda-tb
Comment 2 Jason Scalia 2013-08-08 22:35:03 EDT
Created attachment 784689 [details]
File: anaconda.log
Comment 3 Jason Scalia 2013-08-08 22:35:06 EDT
Created attachment 784690 [details]
File: environ
Comment 4 Jason Scalia 2013-08-08 22:35:10 EDT
Created attachment 784691 [details]
File: lsblk_output
Comment 5 Jason Scalia 2013-08-08 22:35:13 EDT
Created attachment 784692 [details]
File: nmcli_dev_list
Comment 6 Jason Scalia 2013-08-08 22:35:17 EDT
Created attachment 784693 [details]
File: os_info
Comment 7 Jason Scalia 2013-08-08 22:35:20 EDT
Created attachment 784694 [details]
File: program.log
Comment 8 Jason Scalia 2013-08-08 22:35:24 EDT
Created attachment 784695 [details]
File: storage.log
Comment 9 Jason Scalia 2013-08-08 22:35:29 EDT
Created attachment 784696 [details]
File: syslog
Comment 10 Jason Scalia 2013-08-08 22:35:33 EDT
Created attachment 784697 [details]
File: ifcfg.log
Comment 11 Jason Scalia 2013-08-08 22:35:36 EDT
Created attachment 784698 [details]
File: packaging.log
Comment 12 Chris Lumens 2013-08-22 14:53:00 EDT
Can you reproduce this at all?  I'm having a hard time causing this to happen.
Comment 13 Jason Scalia 2013-08-29 12:05:10 EDT
Hello Chris,

I gave this another shot last night and am unfortunately unable to reproduce it.
Comment 14 Chris Lumens 2013-09-09 14:33:56 EDT
Thanks for trying again.  If you are able to reproduce it in the future, feel free to reopen.

Note You need to log in before you can comment on or make changes to this bug.