Bug 995309 - New version request
New version request
Status: CLOSED DUPLICATE of bug 989936
Product: Fedora
Classification: Fedora
Component: gmpy (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Michael J Gruber
Fedora Extras Quality Assurance
:
Depends On: 989936
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-08 23:05 EDT by Christopher Meng
Modified: 2013-08-19 21:16 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-19 21:16:00 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Christopher Meng 2013-08-08 23:05:33 EDT
News
July 27, 2013

GMPY2 2.0.1 has been released. A few minor bugs have been fixed and the logic used in setup.py to find the required libraries has been updated.

A source-only update to GMPY 1.17 has been released. The only change is adding support for third-party extensions to use GMPY under Python 3 (support was working in Python 2 ).

March 24, 2013

GMPY2 2.0.0 has been released. There are a few minor changes and bug fixes. The most significant change is an updated setup.py that tries to simplify the build process.

Due to changes required to integrate support for MPFR and MPC, GMPY2 is not 100% compatible with GMPY. The development versions of mpmath and Sympy both support GMPY2.

Since major version change, still no API/ABI dump.
Comment 1 Michael J Gruber 2013-08-09 03:35:23 EDT
gmpy 1.17 would be a valid update. It's on TO DO. But from a first look at svn, 1.17 introduces more changes than just Py3 extension API. Have you checked?

gmpy2 is incompatible as per the quoted release notes. Are the rawhide versions of mpmath etc. bumped to the devel versions?
Comment 2 Christopher Meng 2013-08-09 05:01:27 EDT
(In reply to Michael J Gruber from comment #1)
> gmpy 1.17 would be a valid update. It's on TO DO. But from a first look at
> svn, 1.17 introduces more changes than just Py3 extension API. Have you
> checked?
> 
> gmpy2 is incompatible as per the quoted release notes. Are the rawhide
> versions of mpmath etc. bumped to the devel versions?

No, let's wait.

1.17 first, please.
Comment 3 Michael J Gruber 2013-08-09 05:48:48 EDT
So, is this bug about 1.17 only? In that case it is a dupe of bug #989936.

Please clarify what your request is about:

1.17 only - then it's a dupe

2.* - check on mathmp etc. and update bug description.
Comment 4 Christopher Meng 2013-08-19 21:16:00 EDT

*** This bug has been marked as a duplicate of bug 989936 ***

Note You need to log in before you can comment on or make changes to this bug.