This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 995320 - [Sign up] CAPTCHA is missing
[Sign up] CAPTCHA is missing
Status: CLOSED NOTABUG
Product: Zanata
Classification: Community
Component: Deployment (Show other bugs)
3.0
Unspecified Unspecified
unspecified Severity urgent
: ---
: ---
Assigned To: Carlos Munoz
Zanata-QA Mailling List
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-09 00:11 EDT by Ding-Yi Chen
Modified: 2013-09-10 01:34 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-10 01:34:21 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ding-Yi Chen 2013-08-09 00:11:20 EDT
Description of problem:
In Sign Up view, the CAPTCHA does not display.

Version-Release number of selected component (if applicable):
Zanata version 3.0.0-alpha-2-SNAPSHOT (20130809-1309)

How reproducible:
Always

Steps to Reproduce:
1. Go to Sign Up view by clicking "Sign Up"

Actual results:
CAPTCHA is missing, as if the link is broken.


Expected results:
CAPTCHA is shown and readable.


Additional info:
Comment 1 Alex Eng 2013-08-09 00:36:08 EDT
Basically the page can't load up the captcha image in the register page, but locally, it works fine (fedora).
Apparently it only happens in our test machine, which is newly built i believed.

This is the stack trace when I try to access to the image url directly - /zanata/seam/resource/captcha
http://pastebin.com/ihyTcEFR

After searching and follow instructions from - install dejavu* packages in one of our test machine - zanata-fedora
http://stackoverflow.com/questions/4438839/java-on-debian-probable-fatal-error-no-fonts-found

The captcha works after jboss restart. dejavu* are font packages.

Again, not sure if our old test machines already have those packages installed or its something new.

We will need to test our production machines for openId and internal authentication for this bug to make sure the captcha image loads up. Check if the dejavu* packages is installed.
Comment 2 Ding-Yi Chen 2013-08-09 01:15:29 EDT
So the root cause is font package is missing. 

Installation Guide is updated accordingly:

https://github.com/zanata/zanata-server/wiki/Installation-Guide#15-fonts-for-captcha-to-work

Since its a configuration issue, I will close it as NOTABUG.
Comment 3 Sean Flanigan 2013-08-11 22:07:20 EDT
We should keep this open until the puppet scripts have been updated.
Comment 4 Alex Eng 2013-09-10 01:34:21 EDT
Added puppet script to install needed packages.

Note You need to log in before you can comment on or make changes to this bug.