Bug 995484 - sm-notify: "-v hostname" doesn't work when IPV6_SUPPORT is enabled
sm-notify: "-v hostname" doesn't work when IPV6_SUPPORT is enabled
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: nfs-utils (Show other bugs)
6.4
Unspecified Linux
unspecified Severity medium
: rc
: ---
Assigned To: Steve Dickson
Yin.JianHong
:
: 1127554 (view as bug list)
Depends On:
Blocks: 1172231 1127554 1127560
  Show dependency treegraph
 
Reported: 2013-08-09 10:02 EDT by Ramandeep Arora
Modified: 2016-11-07 22:58 EST (History)
5 users (show)

See Also:
Fixed In Version: nfs-utils-1.2.3-38.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1127554 (view as bug list)
Environment:
Last Closed: 2013-11-21 18:38:58 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
jiyin: needinfo-


Attachments (Terms of Use)

  None (edit)
Description Ramandeep Arora 2013-08-09 10:02:36 EDT
An issue has been encountered by one of the Red Hat Customers, which is,

"sm-notify -v" is broken for IPv4 (nfs-utils-1.2.3-36) when IPv6 support is enabled.

From the below link, I see from the commit that the above sm-notify issue has been resolved under the nfs package version "nfs-utils 1.2.8".

https://www.kernel.org/pub/linux/utils/nfs-utils/1.2.8/1.2.8-ChangeLog

This means that this has been fixed in the upstream project. Whereas, RHEL 6 still ships "nfs-utils 1.2.3".

When will this fix be back-ported to RHEL 6?

Commit ID : 37add3662de0339a75d3bed86a4235fc7efaf18d
Comment 2 Steve Dickson 2013-08-12 13:35:04 EDT
commit 37add3662de0339a75d3bed86a4235fc7efaf18d
Author: Chuck Lever <chuck.lever@oracle.com>
Date:   Fri Apr 19 13:13:57 2013 -0400

    sm-notify: "-v hostname" doesn't work when IPV6_SUPPORT is enabled
Comment 4 Jian Li 2013-08-14 22:20:05 EDT
ack, reproducer refer to comment 0
Comment 6 Yin.JianHong 2013-08-19 05:52:50 EDT
> sm-notify: "-v hostname" doesn't work when IPV6_SUPPORT is enabled

Hi steved,
  I can not reproduce this issue.
  could you tell me how to enable the "IPV6_SUPPORT",
    and how to config the client and server point  for reproduce?

  thanks.
Comment 7 Jian Li 2013-08-22 05:51:26 EDT
Hi steve, pls check the result? 

Verify: 
In my test environment, dhcp12-225.nay.redhat.com is non-formal host-name, but sm-notify works well.

[root@hp-xw4600-01 statd]# sm-notify -v hp-xw4600-01.rhts.eng.nay.redhat.com -d -f
sm-notify: Version 1.2.3 starting
sm-notify: Canonical name for my_name 'hp-xw4600-01.rhts.eng.nay.redhat.com': hp-xw4600-01.rhts.eng.nay.redhat.com
sm-notify: Retired record for mon_name dhcp12-225.nay.redhat.com
sm-notify: Added host dhcp12-225.nay.redhat.com to notify list
sm-notify: Effective UID, GID: 29, 29
sm-notify: getaddrinfo(3): Name or service not known
sm-notify: DNS resolution of dhcp12-225.nay.redhat.com failed; retrying later
sm-notify: Host dhcp12-225.nay.redhat.com due in 2 seconds
sm-notify: getaddrinfo(3): Name or service not known
sm-notify: DNS resolution of dhcp12-225.nay.redhat.com failed; retrying later
sm-notify: Host dhcp12-225.nay.redhat.com due in 4 seconds
sm-notify: getaddrinfo(3): Name or service not known


reproduce: 

[root@hp-xw4600-01 statd]# sm-notify -v hp-xw4600-01.rhts.eng.nay.redhat.com -d -f
sm-notify: Version 1.2.3 starting
sm-notify: Retired record for mon_name dhcp12-225.nay.redhat.com
sm-notify: Added host dhcp12-225.nay.redhat.com to notify list
sm-notify: Invalid bind address or port for RPC socket: No address associated with hostname
Comment 8 Steve Dickson 2013-08-22 09:25:30 EDT
(In reply to Jian Li from comment #7)
> Hi steve, pls check the result? 
> 
> Verify: 
> In my test environment, dhcp12-225.nay.redhat.com is non-formal host-name,
> but sm-notify works well.
> 
> [root@hp-xw4600-01 statd]# sm-notify -v hp-xw4600-01.rhts.eng.nay.redhat.com
> -d -f
> sm-notify: Version 1.2.3 starting
> sm-notify: Canonical name for my_name
> 'hp-xw4600-01.rhts.eng.nay.redhat.com': hp-xw4600-01.rhts.eng.nay.redhat.com
> sm-notify: Retired record for mon_name dhcp12-225.nay.redhat.com
> sm-notify: Added host dhcp12-225.nay.redhat.com to notify list
> sm-notify: Effective UID, GID: 29, 29
> sm-notify: getaddrinfo(3): Name or service not known
> sm-notify: DNS resolution of dhcp12-225.nay.redhat.com failed; retrying later
> sm-notify: Host dhcp12-225.nay.redhat.com due in 2 seconds
> sm-notify: getaddrinfo(3): Name or service not known
> sm-notify: DNS resolution of dhcp12-225.nay.redhat.com failed; retrying later
> sm-notify: Host dhcp12-225.nay.redhat.com due in 4 seconds
> sm-notify: getaddrinfo(3): Name or service not known
> 
> 
> reproduce: 
> 
> [root@hp-xw4600-01 statd]# sm-notify -v hp-xw4600-01.rhts.eng.nay.redhat.com
> -d -f
> sm-notify: Version 1.2.3 starting
> sm-notify: Retired record for mon_name dhcp12-225.nay.redhat.com
> sm-notify: Added host dhcp12-225.nay.redhat.com to notify list
> sm-notify: Invalid bind address or port for RPC socket: No address
> associated with hostname

It looks like your having DNS problems.... What is the output of 
host dhcp12-225.nay.redhat.com?
Comment 9 Jian Li 2013-08-22 21:50:36 EDT
(In reply to Steve Dickson from comment #8)

> It looks like your having DNS problems.... What is the output of 
> host dhcp12-225.nay.redhat.com?

Yes, DNS dhcp12-225.nay.redhat.com have problem, I just want to check whether sm-notify can work.

I retest with another system. 

[root@dhcp-13-188 statd]# sm-notify -v dhcp-13-188.nay.redhat.com -d -f 
sm-notify: Version 1.2.3 starting
sm-notify: Canonical name for my_name 'dhcp-13-188.nay.redhat.com': dhcp-13-188.nay.redhat.com
sm-notify: Retired record for mon_name hp-xw4600-01.rhts.eng.nay.redhat.com
sm-notify: Added host hp-xw4600-01.rhts.eng.nay.redhat.com to notify list
sm-notify: Effective UID, GID: 29, 29
sm-notify: Sending PMAP_GETPORT for 100024, 1, udp
sm-notify: Host hp-xw4600-01.rhts.eng.nay.redhat.com due in 2 seconds
sm-notify: Received packet...
sm-notify: Received PMAP_GETPORT result: 34629
sm-notify: Sending SM_NOTIFY for dhcp-13-188.nay.redhat.com
sm-notify: Host hp-xw4600-01.rhts.eng.nay.redhat.com due in 4 seconds
sm-notify: Received packet...
sm-notify: Sending SM_NOTIFY for dhcp-13-188.nay.redhat.com
sm-notify: Host hp-xw4600-01.rhts.eng.nay.redhat.com due in 8 seconds
sm-notify: Received packet...
sm-notify: Host hp-xw4600-01.rhts.eng.nay.redhat.com notified successfully
sm-notify: Removing hp-xw4600-01.rhts.eng.nay.redhat.com (10.66.86.85, dhcp-13-188) from notify list
[root@dhcp-13-188 statd]# echo $? 
0
Comment 10 Yin.JianHong 2013-09-10 03:48:37 EDT
verified by /CoreOS/nfs-utils/commands/utils/sm-notify
    https://beaker.engineering.redhat.com/jobs/491203
    https://beaker.engineering.redhat.com/jobs/491232
Comment 12 errata-xmlrpc 2013-11-21 18:38:58 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1714.html
Comment 13 Steve Dickson 2015-11-02 15:28:02 EST
*** Bug 1127554 has been marked as a duplicate of this bug. ***
Comment 14 Tom Coughlan 2015-11-05 11:33:06 EST
Removing from the 68FileAndStorageRPL.

Note You need to log in before you can comment on or make changes to this bug.