Bug 9955 - Fix for sgml2latex error (sgml-tools-1.0.9-2.i386.rpm).
Summary: Fix for sgml2latex error (sgml-tools-1.0.9-2.i386.rpm).
Status: CLOSED DUPLICATE of bug 4114
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: sgml-tools   
(Show other bugs)
Version: 6.1
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Tim Waugh
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-03-04 12:26 UTC by nkbj
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-05-08 15:00:20 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch for sgml-tools-1.0.9-2.i386.rpm (1.16 KB, patch)
2000-03-04 12:27 UTC, nkbj
no flags Details | Diff

Description nkbj 2000-03-04 12:26:29 UTC
sgml2latex gives an error which says something like this:

"Language is not defined: English" (I can't remember the precise words).

The bug is fixed by this patch:

--- /usr/lib/sgml-tools/dist/sgmltool/latex2e/mapping.rpmorig   Mon Mar 22
05:29:40 1999
+++ /usr/lib/sgml-tools/dist/sgmltool/latex2e/mapping   Sat Mar  4 13:03:38
2000
@@ -4,7 +4,7 @@
 <qwertz>       +
 </qwertz>      +

-<article>      + "\\documentclass\[a4paper\]{article}\n"
+<article>      + "\\documentclass\[a4paper,english\]{article}\n"
                        "\\usepackage{linuxdoc-sgml}\n"
                        "\\usepackage{qwertz}\n"
                        "\\usepackage{url}\n"
@@ -19,7 +19,7 @@

 </article>     +       "\\end{document}"       +

-<report>       + "\\documentclass\[a4paper\]{report}\n"
+<report>       + "\\documentclass\[a4paper,english\]{report}\n"
                        "\\usepackage{linuxdoc-sgml}\n"
                        "\\usepackage{qwertz}\n"
                        "\\usepackage{url}\n"
@@ -35,7 +35,7 @@

 </report>      +       "\\end{document}"       +

-<book> +       "\\documentclass\[a4paper\]{book}\n"
+<book> +       "\\documentclass\[a4paper,english\]{book}\n"
                        "\\usepackage{linuxdoc-sgml}\n"
                        "\\usepackage{qwertz}\n"
                        "\\usepackage{url}\n"
@@ -52,7 +52,7 @@
 </book>                +       "\\end{document}"       +


-<notes> +      "\\documentclass\[a4paper\]{article}\n"
+<notes> +      "\\documentclass\[a4paper,english\]{article}\n"
                        "\\usepackage{linuxdoc-sgml}\n"
                        "\\usepackage{qwertz}\n"
                        "\\usepackage{url}\n"

Comment 1 nkbj 2000-03-04 12:27:59 UTC
Created attachment 140 [details]
Patch for sgml-tools-1.0.9-2.i386.rpm

Comment 2 Bill Nottingham 2000-06-10 22:04:46 UTC
This should have been fixed in sgml-tools-1.0.9-5 and
later.

*** This bug has been marked as a duplicate of 4114 ***


Note You need to log in before you can comment on or make changes to this bug.