Bug 99553 - amd64 should be alias to x86_64
amd64 should be alias to x86_64
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 2.1
Classification: Red Hat
Component: rpm (Show other bugs)
2.1
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Johnson
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-07-21 16:00 EDT by Marc J. Miller
Modified: 2007-11-30 17:06 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-07-26 23:30:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Marc J. Miller 2003-07-21 16:00:34 EDT
Description of problem:
amd64 (lowercase) should be an alias to x86_64, such that file name 
rpmname.amd64.rpm should be able to upgrade an rpmname.x86_64.rpm of lower 
version number.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
    
Actual results:


Expected results:


Additional info:
AMD64 was announced on April 22, 2003.  On that date, x86-64 became only 
the "old" name of the instruction set, architecture, and technology.
Comment 1 Jeff Johnson 2003-07-23 13:55:38 EDT
Process started in rpm by adding alias for amd64. Gonna take a bit
for s/x86_64/amd64/ to happen in file names, next "make world"
rebuild at least a couple months away.

Off to kernel in the vain hope that uname(2) might return "amd64"
rather than "x86_64". Bounce back to rpm when you refuse to make
the change so that I can add the necessary code to rpm.

Or close if alias is the only issue.
Comment 2 Ernie Petrides 2004-03-26 18:39:00 EST
Jeff/Marc, we can't change the kernel's uname() strings in RHEL 3
due to compatibility issues.  However, I believe that our intent
in RHEL 4 is to move towards using amd64 (as opposed to ia32e) in
RPM file names.

What should I do with this bugzilla?  Bounce back to "rpm"?  Close
as fixed in next release?  Close as won't fix?  It's up to you.
Comment 4 Jeremy Katz 2004-07-26 23:30:52 EDT
Unfortunately, this is sort of more fun now with EM64T in the world.

For RHEL4, x86_64 is the generic form (ie, will work on both amd64 and
em64t) and we can go to the more specific versions if we end up
deciding that further optimization/separation at other than runtime is
useful.

Note You need to log in before you can comment on or make changes to this bug.