Bug 995551 - regression: gthumb crashes on moving a file
regression: gthumb crashes on moving a file
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: gthumb (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Christian Krause
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-09 13:10 EDT by Need Real Name
Modified: 2013-08-23 20:03 EDT (History)
2 users (show)

See Also:
Fixed In Version: gthumb-3.2.3-2.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-23 20:03:23 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 705877 None None None Never
Red Hat Bugzilla 995724 None None None Never

  None (edit)
Description Need Real Name 2013-08-09 13:10:11 EDT
Description of problem:
gthumb crashes when I move a jpg file to another directory

Version-Release number of selected component (if applicable):
gthumb-3.2.3-1.fc19.x86_64

How reproducible:
every time

Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
More info soon.
Comment 1 Need Real Name 2013-08-12 05:18:19 EDT
This seems to be related to movie files and creating thumbnails (even though movies are disabled in preferences).
Comment 2 Need Real Name 2013-08-12 17:44:13 EDT
The console shows the following error:
 totem-video-thumbnailer couldn't open file 'file:///home/blah/blah.mov'

This is a regression and a crash bug, any chance you could up the severity?
Comment 3 Need Real Name 2013-08-16 05:33:40 EDT
This crasher is fixed upstream. Any chance of a backport?
 https://git.gnome.org/browse/gthumb/commit/?h=gthumb-3-2&id=8535630899875e6486556362e7ef192f3db2eb3e
Comment 4 Christian Krause 2013-08-18 12:23:09 EDT
I tried to reproduce the problem:

- I can reproduce the issue described in https://bugzilla.redhat.com/show_bug.cgi?id=995724 

- but it looks like that this is a different problem because the console output is different:

gthumb: symbol lookup error: /usr/lib/gthumb/extensions/libgstreamer_tools.so: undefined symbol: gst_is_video_overlay_prepare_window_handle_message

- the suggest upstream patch does not help for problem 995724

So far, I can't reproduce the problem of this bug report.

Occasionally (if the thumbnails cache is empty), I see the error messages from comment #2, but it does not seem to cause a crash.


Please can you try to describe exactly how the problem can be reproduced?
Comment 5 Need Real Name 2013-08-18 14:54:09 EDT
Are you using Dropbox by any chance? I have a feeling this might be linked to the com.dropbox.attributes xattr which a Mac writes...
Comment 6 Christian Krause 2013-08-20 03:30:49 EDT
Eventually I could reproduce the issue by copying a file with "Copy To..." into my home directory.
Comment 7 Fedora Update System 2013-08-20 03:32:11 EDT
gthumb-3.2.3-2.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/gthumb-3.2.3-2.fc19
Comment 8 Fedora Update System 2013-08-20 20:08:21 EDT
Package gthumb-3.2.3-2.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing gthumb-3.2.3-2.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-15055/gthumb-3.2.3-2.fc19
then log in and leave karma (feedback).
Comment 9 Need Real Name 2013-08-22 15:50:38 EDT
WFM thanks!
Comment 10 Fedora Update System 2013-08-23 20:03:23 EDT
gthumb-3.2.3-2.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.