Bug 995561 - openlmi-software mof file can not be registered with sblim-sfcb
openlmi-software mof file can not be registered with sblim-sfcb
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: openlmi-storage (Show other bugs)
rawhide
All Linux
unspecified Severity medium
: ---
: ---
Assigned To: Jan Safranek
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-09 13:43 EDT by Michal Minar
Modified: 2013-08-15 07:39 EDT (History)
10 users (show)

See Also:
Fixed In Version: openlmi-providers-0.1.1-2.fc20 openlmi-storage-0.5.3-3.fc20
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-15 07:39:32 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michal Minar 2013-08-09 13:43:41 EDT
Description of problem:
  Classes __MethodParameters* recently added to work around issue in tog-pegasus (bz920763) do not pass syntax check of mofcomp when registering classes with sblim-sfcb.

Version-Release number of selected component (if applicable):
  sblim-sfcb-1.3.16-8.fc20.x86_64
  openlmi-software-0.1.1-1.fc20.noarch

How reproducible:
  always

Steps to Reproduce:
1. install openlmi-software
2. install sblim-sfcb 
3. cd /usr/share/openlmi-providers
4. try to register openlmi-software with sfcb by issuing:
5.   $ openlmi-mof-register -c sfcbd --just-mofs register 05_LMI_Qualifiers.mof 30_LMI_Jobs.mof
6.   $ openlmi-mof-register -c sfcbd register 60_LMI_Software.mof LMI_Software.reg

Actual results:
  This is an output of command from point 6:
  2013-08-09 19:34:04 STARTING ../openlmi-mof-register -c sfcbd -v 0.1.1 register 60_LMI_Software.mof LMI_Software.reg
2013-08-09 19:34:04 COMMAND: /usr/bin/sfcbstage -n root/cimv2 -r LMI_Software.reg 60_LMI_Software.mof
2013-08-09 19:34:04 EXIT CODE: 0
2013-08-09 19:34:04 COMMAND: /usr/bin/sfcbrepos -f
error in /var/lib/sfcb/stage/mofs/root/cimv2/60_LMI_Software.mof line 932 near __MethodParameters_InstallFromSoftwareIdentity: class name __MethodParameters_InstallFromSoftwareIdentity invalid (missing schema prefix)
error in /var/lib/sfcb/stage/mofs/root/cimv2/60_LMI_Software.mof line 936 near __MethodParameters_InstallFromURI: class name __MethodParameters_InstallFromURI invalid (missing schema prefix)
error in /var/lib/sfcb/stage/mofs/root/cimv2/60_LMI_Software.mof line 940 near __MethodParameters_InstallFromByteStream: class name __MethodParameters_InstallFromByteStream invalid (missing schema prefix)
error in /var/lib/sfcb/stage/mofs/root/cimv2/60_LMI_Software.mof line 944 near __MethodParameters_VerifyInstalledIdentity: class name __MethodParameters_VerifyInstalledIdentity invalid (missing schema prefix)
error in /var/lib/sfcb/stage/mofs/root/cimv2/60_LMI_Software.mof line 952 near __ReturnValue: class name __MethodParameters_InstallFromSoftwareIdentity_Result invalid (missing schema prefix)
error in /var/lib/sfcb/stage/mofs/root/cimv2/60_LMI_Software.mof line 959 near __ReturnValue: class name __MethodParameters_InstallFromURI_Result invalid (missing schema prefix)
error in /var/lib/sfcb/stage/mofs/root/cimv2/60_LMI_Software.mof line 966 near __ReturnValue: class name __MethodParameters_InstallFromByteStream_Result invalid (missing schema prefix)
error in /var/lib/sfcb/stage/mofs/root/cimv2/60_LMI_Software.mof line 979 near __ReturnValue: class name __MethodParameters_VerifyInstalledIdentity_Result invalid (missing schema prefix)
Failed compiling the MOF files.
2013-08-09 19:34:07 EXIT CODE: 1
2013-08-09 19:34:07 COMMAND: /usr/bin/systemctl reload-or-try-restart sblim-sfcb.service
Failed to issue method call: Unit sblim-sfcb.service failed to load: No such file or directory. See system logs and 'systemctl status sblim-sfcb.service' for details.
2013-08-09 19:34:07 EXIT CODE: 6
2013-08-09 19:34:07 DONE WITH EXIT CODE: 0

Expected results:
  No errors and EXIT CODE: 0


Additional info:
  Caused by class names starting with "__MethodParameters_", which are not valid class names according to mof BNF gramar (schemaName -- that is a word before first '_' -- must not include any '_').

Note You need to log in before you can comment on or make changes to this bug.