Bug 995616 - Imported VMs from 3.2 via an export domain vanish when ovirt-engine is restarted
Imported VMs from 3.2 via an export domain vanish when ovirt-engine is restarted
Status: CLOSED DUPLICATE of bug 990543
Product: oVirt
Classification: Community
Component: ovirt-engine-core (Show other bugs)
3.3
x86_64 Linux
unspecified Severity high
: ---
: 3.3
Assigned To: Arik
virt
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-09 16:51 EDT by Caerie Houchins
Modified: 2013-08-13 02:34 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-13 02:34:04 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
engine.log and vdsm.log (1.10 MB, application/x-gzip)
2013-08-09 16:51 EDT, Caerie Houchins
no flags Details

  None (edit)
Description Caerie Houchins 2013-08-09 16:51:43 EDT
Created attachment 784969 [details]
engine.log and vdsm.log

Description of problem:

Successfully imported VMs into 3.3 beta from a detached Export domain running on 3.2 vanish when ovirt-engine is restarted.  The Event log shows "Failed to import Vm <name> to Data Center <name>, Cluster <name>".

The result is the hosts tab shows vm's running on a host that are not showing up under the Virtual Machines tab.

Version-Release number of selected component (if applicable):
From Ovirt 3.2.2-1.1.43.el6
to
ovirt-engine-3.3.0-0.3.beta1.el6

How reproducible:
Every time

Steps to Reproduce:
1. Import a VM from a detached 3.2 Export Domain
2. Start the VM and wait for it to run successfully
3. stop and start ovirt-engine

Actual results:

All imported VMs are not listed in the Virtual Machine tab while VMs created in 3.3 are listed.

Expected results:

All VMs that were in the Data Center before ovirt-engine restarted should still be in the Data Center.

Additional info:
Adding engine.log and vdsm.log from one of the Hosts
Using PosixFS Glusterfs filesystem as Data Domain and NFS for ISO
All machines running CentOS 6.4
Comment 1 Arik 2013-08-12 06:34:46 EDT
The imported VMs were removed because a task that was created as part of the import command remained after the command ended, which caused the engine to use compensation after the restart. it looks like a duplication of bz 990543, which already been fixed.

Caerie, can you please check if it is reproducible with the latest version?
Comment 2 Caerie Houchins 2013-08-12 13:00:53 EDT
Arik,

Looks like this works with the latest nightly build.

ovirt-engine-websocket-proxy-3.3.0-0.3.beta1.el6.noarch
ovirt-engine-setup-3.3.0-0.2.master.20130811140141.git116071a.el6.noarch
ovirt-engine-restapi-3.3.0-0.2.master.20130811140141.git116071a.el6.noarch
ovirt-engine-webadmin-portal-3.3.0-0.2.master.20130811140141.git116071a.el6.noarch
ovirt-engine-userportal-3.3.0-0.2.master.20130811140141.git116071a.el6.noarch
ovirt-engine-dbscripts-3.3.0-0.2.master.20130811140141.git116071a.el6.noarch
ovirt-engine-3.3.0-0.2.master.20130811140141.git116071a.el6.noarch
ovirt-engine-cli-3.3.0.4-1.20130718.gite0f993f.el6.noarch
ovirt-engine-tools-3.3.0-0.2.master.20130811140141.git116071a.el6.noarch
ovirt-engine-sdk-python-3.3.0.4-1.20130808.gitc6f4610.el6.noarch
ovirt-engine-lib-3.3.0-0.3.beta1.el6.noarch
ovirt-engine-backend-3.3.0-0.2.master.20130811140141.git116071a.el6.noarch

This looks like it's already fixed as stated.
Comment 3 Arik 2013-08-13 02:34:04 EDT
(In reply to Caerie Houchins from comment #2)
> Arik,
> 
> Looks like this works with the latest nightly build.
> 
> ovirt-engine-websocket-proxy-3.3.0-0.3.beta1.el6.noarch
> ovirt-engine-setup-3.3.0-0.2.master.20130811140141.git116071a.el6.noarch
> ovirt-engine-restapi-3.3.0-0.2.master.20130811140141.git116071a.el6.noarch
> ovirt-engine-webadmin-portal-3.3.0-0.2.master.20130811140141.git116071a.el6.
> noarch
> ovirt-engine-userportal-3.3.0-0.2.master.20130811140141.git116071a.el6.noarch
> ovirt-engine-dbscripts-3.3.0-0.2.master.20130811140141.git116071a.el6.noarch
> ovirt-engine-3.3.0-0.2.master.20130811140141.git116071a.el6.noarch
> ovirt-engine-cli-3.3.0.4-1.20130718.gite0f993f.el6.noarch
> ovirt-engine-tools-3.3.0-0.2.master.20130811140141.git116071a.el6.noarch
> ovirt-engine-sdk-python-3.3.0.4-1.20130808.gitc6f4610.el6.noarch
> ovirt-engine-lib-3.3.0-0.3.beta1.el6.noarch
> ovirt-engine-backend-3.3.0-0.2.master.20130811140141.git116071a.el6.noarch
> 
> This looks like it's already fixed as stated.

Thanks for the verification.
So I'm closing this one as a duplicate.

*** This bug has been marked as a duplicate of bug 990543 ***

Note You need to log in before you can comment on or make changes to this bug.