Bug 995694 - bug component not displayed in "--full" output
bug component not displayed in "--full" output
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: python-bugzilla (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Will Woods
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-10 03:12 EDT by Steve Tyler
Modified: 2013-08-15 12:23 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-15 12:11:14 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Steve Tyler 2013-08-10 03:12:28 EDT
Description of problem:
The "--full" option is supposed to "output detailed bug info", but the bug component is not included in the output.

$ bugzilla query -b 995552 --full
#995552 NEW        - Brian C. Lane - livecd-iso-to-disk has an upper limit of 2048 MB writing to FAT32 partitions but 4095 MB will work
CC: Adam Stokes,Brian C. Lane,Bruno Wolff III,David Huff,Jasper O'neal Hartline,Jeremy Katz,M. Edward (Ed) Borasky
Blocked: []
Depends: []
...

$ man bugzilla | less -N
...
    219 OUTPUT FORMAT ‘QUERY’ OPTIONS
    220        --full, -f
    221               output detailed bug info
...

Version-Release number of selected component (if applicable):
python-bugzilla-0.9.0-1.fc19.noarch

How reproducible:
Always.

Steps to Reproduce:
1. $ bugzilla query -b 995552 --full

Actual results:
Bug component is not displayed.

Expected results:
Bug component is displayed.

$ bugzilla query -b 995552 --raw | fgrep '[component]'
ATTRIBUTE[component]: livecd-tools

Additional info:
Comment 1 Cole Robinson 2013-08-15 12:11:14 EDT
Since it's unlikely that the --full option is being parsed by anyone, I've added this bit upstream. Just closing as UPSTREAM since it's a pretty minor addition and we will pick it up with the next release
Comment 2 Steve Tyler 2013-08-15 12:23:17 EDT
Thanks:
bugzilla: Have query --full show component field (bz 995694)
https://git.fedorahosted.org/cgit/python-bugzilla.git/commit/?id=7fdb5e90012bf0a3fe27070331c57a049c200f43

Note You need to log in before you can comment on or make changes to this bug.