Bug 995893 - bouncycastle-mail update breaks package scriplets
bouncycastle-mail update breaks package scriplets
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: bouncycastle-mail (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Juan Hernández
Fedora Extras Quality Assurance
:
: 996329 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-11 17:15 EDT by Michal Jaegermann
Modified: 2013-08-13 03:48 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-12 01:21:01 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michal Jaegermann 2013-08-11 17:15:20 EDT
Description of problem:

bouncycastle-mail-1.46-9.fc20 sports such package scripts:

postinstall scriptlet (using /bin/sh):
%update_maven_depmap
postuninstall scriptlet (using /bin/sh):
%update_maven_depmap

On an update this results in:
 
/var/tmp/rpm-tmp.1ANixh: line 1: fg: no job control
warning: %post(bouncycastle-mail-1.46-9.fc20.noarch) scriptlet failed, exit status 1

Uninstalling this package will fail too resulting in duplicates on an update.

Version-Release number of selected component (if applicable):
bouncycastle-mail-1.46-9.fc20

Additional info:
Such unexpanded rpm macros seem to be more "popular" in recent time.  See, for example, bug 995891 and bug 983760 albeit with a somewhat different "leftovers".
Comment 1 Michael Schwendt 2013-08-13 03:45:51 EDT
*** Bug 996329 has been marked as a duplicate of this bug. ***
Comment 2 Michael Schwendt 2013-08-13 03:48:26 EDT
To package maintainer, *please* add better entries to the %changelog, which sum up what you've changed.

http://pkgs.fedoraproject.org/cgit/bouncycastle-mail.git/diff/

Note You need to log in before you can comment on or make changes to this bug.