Bug 995968 - The 'System Type' of 'Host & Guest Info' is displayed as 'Host' in SAM web UI after a virtual machine register to SAM
The 'System Type' of 'Host & Guest Info' is displayed as 'Host' in SAM web UI...
Status: CLOSED ERRATA
Product: Subscription Asset Manager
Classification: Red Hat
Component: katello (Show other bugs)
1.3
Unspecified Unspecified
unspecified Severity medium
: rc
: ---
Assigned To: Tom McKay
SAM QE List
:
Depends On:
Blocks: sam13-tracker
  Show dependency treegraph
 
Reported: 2013-08-12 01:21 EDT by qianzhan
Modified: 2013-10-01 07:18 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-01 07:18:14 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
'Screenshot from 2013-08-12 13:02:43.png' (150.35 KB, image/png)
2013-08-12 01:33 EDT, qianzhan
no flags Details
'Screenshot from 2013-08-23 14:45:08.png' (174.24 KB, image/png)
2013-08-23 03:16 EDT, qianzhan
no flags Details

  None (edit)
Description qianzhan 2013-08-12 01:21:42 EDT
Description of problem:
The 'System Type' of 'Host & Guest Info' is displayed as 'Host' in SAM web UI after a virtual machine register to SAM

Version-Release number of selected component (if applicable):
katello-candlepin-cert-key-pair-1.0-1.noarch
katello-certs-tools-1.4.2-2.el6sat.noarch
katello-cli-1.4.3-5.el6sat.noarch
katello-cli-common-1.4.3-5.el6sat.noarch
katello-common-1.4.3-6.el6sam_splice.noarch
katello-configure-1.4.4-2.el6sat.noarch
katello-glue-candlepin-1.4.3-6.el6sam_splice.noarch
katello-glue-elasticsearch-1.4.3-6.el6sam_splice.noarch
katello-headpin-1.4.3-6.el6sam_splice.noarch
katello-headpin-all-1.4.3-6.el6sam_splice.noarch
katello-selinux-1.4.4-2.el6sat.noarch
signo-katello-0.0.10-2.el6sat.noarch
candlepin-0.8.19-1.el6sam.noarch
candlepin-scl-1-5.el6_4.noarch
candlepin-scl-quartz-2.1.5-5.el6_4.noarch
candlepin-scl-rhino-1.7R3-1.el6_4.noarch
candlepin-scl-runtime-1-5.el6_4.noarch
candlepin-selinux-0.8.19-1.el6sam.noarch
candlepin-tomcat6-0.8.19-1.el6sam.noarch
thumbslug-0.0.32-1.el6sam.noarch
thumbslug-selinux-0.0.32-1.el6sam.noarch
subscription-manager-1.8.19-1.el5

How reproducible:
always

Steps to Reproduce:
1. Register a virtual machine to SAM
[root@i-am-a-virtual-machine ~]# subscription-manager register
Username: admin
Password: 
The system has been registered with ID: b4641bbc-4414-4bee-926b-72d867b28abb 

2. Check the 'Host & Guest Info' on SAM web UI
The 'System Type' of 'Host & Guest Info' is displayed as 'Host' in SAM web UI after a virtual machine register to SAM.


Actual results:
As above.

Expected results:
The 'System Type' of 'Host & Guest Info' is displayed as 'Guest' in SAM web UI after a virtual machine register to SAM. And the next field below 'System Type' is 'Host' with host's uuid.

Additional info:
The katello-debug info is attached as 'Screenshot from 2013-08-12 13:02:43.png'
Comment 1 qianzhan 2013-08-12 01:32:46 EDT
> Additional info:
> The katello-debug info is attached as 'Screenshot from 2013-08-12
> 13:02:43.png'

The 'Additional info' is wrong!!!And the new additional infos are:
(1) Actual result can be seen in attachment 'Screenshot from 2013-08-12 13:02:43.png'
(2) The katello-debug info is attached as 'katello-debug info'
Comment 2 qianzhan 2013-08-12 01:33:24 EDT
Created attachment 785556 [details]
'Screenshot from 2013-08-12 13:02:43.png'
Comment 4 Tom McKay 2013-08-14 16:06:49 EDT
Branch: refs/heads/master
  Home:   https://github.com/Katello/katello
  Commit: c6ea248f15e0ba882d9fb6ce3cbfadac0892909d
      https://github.com/Katello/katello/commit/c6ea248f15e0ba882d9fb6ce3cbfadac0892909d
  Author: Tom McKay <thomasmckay@redhat.com>
  Date:   2013-08-14 (Wed, 14 Aug 2013)
Comment 6 qianzhan 2013-08-23 03:15:40 EDT
Verifying Version:

katello-candlepin-cert-key-pair-1.0-1.noarch
katello-certs-tools-1.4.2-2.el6sat.noarch
katello-cli-1.4.3-8.el6sat.noarch
katello-cli-common-1.4.3-8.el6sat.noarch
katello-common-1.4.3-9.el6sam_splice.noarch
katello-configure-1.4.4-3.el6sat.noarch
katello-glue-candlepin-1.4.3-9.el6sam_splice.noarch
katello-glue-elasticsearch-1.4.3-9.el6sam_splice.noarch
katello-headpin-1.4.3-9.el6sam_splice.noarch
katello-headpin-all-1.4.3-9.el6sam_splice.noarch
katello-selinux-1.4.4-2.el6sat.noarch
signo-katello-0.0.20-1.el6sat.noarch
candlepin-0.8.21-1.el6sam.noarch
candlepin-scl-1-5.el6_4.noarch
candlepin-scl-quartz-2.1.5-5.el6_4.noarch
candlepin-scl-rhino-1.7R3-1.el6_4.noarch
candlepin-scl-runtime-1-5.el6_4.noarch
candlepin-selinux-0.8.21-1.el6sam.noarch
candlepin-tomcat6-0.8.21-1.el6sam.noarch
thumbslug-0.0.32-1.el6sam.noarch
thumbslug-selinux-0.0.32-1.el6sam.noarch
subscription-manager-gui-1.8.20-1.el5
subscription-manager: 1.8.20-1.el5
python-rhsm: 1.8.16-1.el5

1. Register the host and guest against the same SAM server, and check the 'Host & Guest Info' on SAM web UI:

The 'Host & Guest Info' field is correct now, and please see the attachment 'Screenshot from 2013-08-23 14:45:08.png' for details.

Marking the status to 'VERIFIED'.
Comment 7 qianzhan 2013-08-23 03:16:38 EDT
Created attachment 789493 [details]
'Screenshot from 2013-08-23 14:45:08.png'
Comment 9 errata-xmlrpc 2013-10-01 07:18:14 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2013-1390.html

Note You need to log in before you can comment on or make changes to this bug.