Bug 995999 - [engine-backend] task remians in DB after LSM failure during VmReplicateDiskFinishVDSCommand
[engine-backend] task remians in DB after LSM failure during VmReplicateDiskF...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine (Show other bugs)
3.3.0
x86_64 Unspecified
unspecified Severity high
: ---
: 3.3.0
Assigned To: Daniel Erez
Leonid Natapov
storage
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-12 03:31 EDT by Elad
Modified: 2016-02-10 14:09 EST (History)
10 users (show)

See Also:
Fixed In Version: is10
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Storage
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
scohen: Triaged+


Attachments (Terms of Use)
logs (2.99 MB, application/x-gzip)
2013-08-12 03:31 EDT, Elad
no flags Details

  None (edit)
Description Elad 2013-08-12 03:31:51 EDT
Created attachment 785584 [details]
logs

Description of problem:
Engine reports about a running live storage migration task, even though the operation failed and cleaned by vdsm.


Version-Release number of selected component (if applicable):
rhevm-3.3.0-0.14.master.el6ev.noarch


How reproducible:
Unknown

Steps to Reproduce:
On a DC with more than 1 host and more than 1 SD (block):
- create a vm from template
- run the vm on HSM
- live migrate the vm disk
- during VmReplicateDiskFinishVDSCommand, restart vdsm on SPM

Actual results:
Other host takes SPM after the failure and tasks are being cleaned by SPM
SPM has no running tasks:

Thread-302514::INFO::2013-08-12 10:10:09,177::logUtils::47::dispatcher::(wrapper) Run and protect: getAllTasksInfo, Return response: {'allTasksInfo': {}}

Engine reports about a running live storage migration task:

              task_id                | action_type | status | result |                                action_parameters                                |                       action_params_class
--------------------------------------+-------------+--------+--------+---------------------------------------------------------------------------------+------------------------------------------------------------
 c6649692-0053-4aa1-913a-48eef0ffa6fc |        1010 |      2 |      0 | {                                                                               | org.ovirt.engine.core.common.action.LiveMigrateDiskParamete
                                                                      :   "@class" : "org.ovirt.engine.core.common.action.LiveMigrateDiskParameters",
                                                                      :   "commandId" : [ "org.ovirt.engine.core.compat.Guid", {
                                                                      :     "uuid" : "8fb6dced-e3eb-4c77-9f4e-c86504634d7b"
                                                                      :   } ],
                                                                      :   "parametersCurrentUser" : {
                                                                      :     "groupIds" : "",
                                                                      :     "password" : null,
                                                                      :     "userName" : "admin@internal",
                                                                      :     "userId" : [ "org.ovirt.engine.core.compat.Guid", {
                                                                      :       "uuid" : "fdfc627c-d875-11e0-90f0-83df133b58cc"




Expected results:
Engine should be updated about SPM tasks. 

Additional info:
Comment 1 Allon Mureinik 2013-08-13 02:14:07 EDT
Daniel, isn't this a dup of something you've already handled?
Comment 2 Daniel Erez 2013-08-15 12:08:18 EDT
The described problem should have already been fixed by:
http://gerrit.ovirt.org/#/c/17582/

Elad, can you please verify whether the issue is reproduced on latest build?
Comment 4 Leonid Natapov 2013-09-17 10:26:52 EDT
si14.
Comment 5 Itamar Heim 2014-01-21 17:21:31 EST
Closing - RHEV 3.3 Released
Comment 6 Itamar Heim 2014-01-21 17:26:51 EST
Closing - RHEV 3.3 Released

Note You need to log in before you can comment on or make changes to this bug.