Bug 996041 - add provider - openstack network - networking plugin field doesn't show all values after selection
add provider - openstack network - networking plugin field doesn't show all v...
Status: CLOSED NOTABUG
Product: oVirt
Classification: Community
Component: ovirt-engine-webadmin (Show other bugs)
3.3
Unspecified Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: Mike Kolesnik
network
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-12 05:46 EDT by Alissa
Modified: 2013-09-08 01:03 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-08 01:03:21 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
before selecting a value (177.49 KB, image/png)
2013-08-12 05:46 EDT, Alissa
no flags Details
after selecting a value (179.56 KB, image/png)
2013-08-12 05:47 EDT, Alissa
no flags Details
beforeSelection (113.24 KB, image/png)
2013-08-12 05:50 EDT, Alissa
no flags Details
afterSelection (99.02 KB, image/png)
2013-08-12 05:50 EDT, Alissa
no flags Details

  None (edit)
Description Alissa 2013-08-12 05:46:42 EDT
Created attachment 785625 [details]
before selecting a value

Description of problem:
add provider dialog - openstack network type -  networking plugin field
There are currently 2 values shown in the dropdown list - Linux bridge and Open vswitch.
After selecting one of the values,, pressing on the field again shows just the selected value, it doesn't show all other options as in regular dropdown lists.
In order to see all options, user needs to erase the currently selected value, and only then all options reappear.
please see attachments.

Version-Release number of selected component (if applicable):
3.3

How reproducible:
always

Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:
all options to be shown

Additional info:
Comment 1 Alissa 2013-08-12 05:47:22 EDT
Created attachment 785626 [details]
after selecting a value
Comment 2 Alissa 2013-08-12 05:50:23 EDT
Created attachment 785627 [details]
beforeSelection
Comment 3 Alissa 2013-08-12 05:50:53 EDT
Created attachment 785629 [details]
afterSelection
Comment 4 Mike Kolesnik 2013-08-25 05:19:26 EDT
This is not a bug, as it's a suggestion list for a free text field, not a "run of the mill" drop-down list.

This is the way this UI widget behaves across the system (for example, when entering bond name).

If you have another idea how to eanble free text and pre-defined values, feel free to make it.
Comment 5 Alissa 2013-08-25 06:21:49 EDT
It looks like a regular dropdown list which offers values to select, and then some values are not displayed.
How a user should know that this is a free text field? 
Einav - perhaps you have an input on this?
Comment 6 Einav Cohen 2013-09-05 17:01:27 EDT
hi Alissa, I apologize for the late response.

as Mike mentioned in comment #4, the widget is not a combo-box [which offers a set of pre-defined values to choose from, regardless of the field's current value] - it is text-field with an auto-complete functionality [which offers completion options based on a user-filled prefix / current field value, much like the google search bar or even the ovirt-engine's search bar].

IIUC, when the field is empty, the widget simply offers all of the available options (much like a combo-box), since the empty prefix "matches" all of the available options. When the field is already filled with one of the options, attempting to edit it offers only values that match the current (non-empty) "prefix" in the field.

As far as I can see (looking at both of the screen-shots that you have provided), the widget doesn't contain the classic down-arrow-button on its right-hand side (like the Type field in the same dialog, for example) that you would expect to see in a combo-box, therefore I don't think that there is an issue here with the user confusing the text-field-with-auto-complete to be a combo-box by mistake.

I am not sure if this field can contain a value that is not one of the available options; if it can't (i.e. the field value is limited to a closed set of values), then maybe we can consider an Improvement of turning this widget into a combo-box, which might be more appropriate here (we can discuss this on the 'users' mailing list); but as it is now - I don't see a buggy behavior here.

if you have any further question/concerns, feel free to 'needinfo' me again. thanks.
Comment 7 Mike Kolesnik 2013-09-08 01:03:21 EDT
(In reply to Einav Cohen from comment #6)
> hi Alissa, I apologize for the late response.
> 
> as Mike mentioned in comment #4, the widget is not a combo-box [which offers
> a set of pre-defined values to choose from, regardless of the field's
> current value] - it is text-field with an auto-complete functionality [which
> offers completion options based on a user-filled prefix / current field
> value, much like the google search bar or even the ovirt-engine's search
> bar].
> 
> IIUC, when the field is empty, the widget simply offers all of the available
> options (much like a combo-box), since the empty prefix "matches" all of the
> available options. When the field is already filled with one of the options,
> attempting to edit it offers only values that match the current (non-empty)
> "prefix" in the field.
> 
> As far as I can see (looking at both of the screen-shots that you have
> provided), the widget doesn't contain the classic down-arrow-button on its
> right-hand side (like the Type field in the same dialog, for example) that
> you would expect to see in a combo-box, therefore I don't think that there
> is an issue here with the user confusing the text-field-with-auto-complete
> to be a combo-box by mistake.
> 
> I am not sure if this field can contain a value that is not one of the
> available options; if it can't (i.e. the field value is limited to a closed
> set of values), then maybe we can consider an Improvement of turning this
> widget into a combo-box, which might be more appropriate here (we can
> discuss this on the 'users' mailing list); but as it is now - I don't see a
> buggy behavior here.

Indeed the user can input his own selection, and not use one of the proposals. This is why this type of widget was chosen.

> 
> if you have any further question/concerns, feel free to 'needinfo' me again.
> thanks.

Closing per Einav's detailed explanation.

Note You need to log in before you can comment on or make changes to this bug.