Bug 996044 - [Admin Portal] New VM ignores osinfo properties for network card, it is always VirtIO
[Admin Portal] New VM ignores osinfo properties for network card, it is alway...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-webadmin-portal (Show other bugs)
unspecified
Unspecified Unspecified
medium Severity medium
: ---
: 3.4.0
Assigned To: Lior Vernia
Martin Pavlik
network
: EasyFix, Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-12 05:50 EDT by Jiri Belka
Modified: 2016-02-10 14:57 EST (History)
13 users (show)

See Also:
Fixed In Version: org.ovirt.engine-root-3.4.0-14
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Network
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
engine.log (6.97 KB, application/x-gzip)
2013-08-12 05:50 EDT, Jiri Belka
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 26925 master MERGED webadmin: Set default vNIC type according to OsInfo Never
oVirt gerrit 26948 ovirt-engine-3.4 MERGED webadmin: Set default vNIC type according to OsInfo Never

  None (edit)
Description Jiri Belka 2013-08-12 05:50:44 EDT
Created attachment 785628 [details]
engine.log

Description of problem:
New VM dialog ignores osinfo properties for network card, it is always VirtIO.

Version-Release number of selected component (if applicable):
is9.1

How reproducible:
100%

Steps to Reproduce:
1. echo 'os.windows_xp.devices.network.value = e1000' > /etc/ovirt-engine/osinfo.conf.d/06-overridesectvalues.properties
2. /etc/init.d/ovirt-engine restart
3. New VM - Desktop - Windows XP
4. Check type of network adapter of the guest

Actual results:
VirtIO

Expected results:
e1000

Additional info:
it looks like this automatically added network card is always VirtIO.
check 'osinfo-test' in the log
Comment 1 Roy Golan 2014-02-17 05:31:44 EST
UI Problem not osinfo
I'm checking that on 3.3 and the problem is a bit different - after confirming the new VM dialog, the VM is created but a canDo action popup rises following create vm interface command. 

Open the interfaces subtab and create a new interface and the UI and you'll see the dropdown is populated with virtio and e1000.

Lior?
Comment 2 Lior Vernia 2014-03-31 01:39:51 EDT
I'm not sure what's the "problem". Is the default type of vNIC supposed to be determined by osinfo? If so, I don't think this was ever implemented. If you create a new vNIC through the VM/interfaces subtab, you'll see that the default choice there is VirtIO as well, the only difference is that there's no widget to change that in the new VM dialog.
Comment 3 Roy Golan 2014-03-31 02:07:16 EDT
(In reply to Lior Vernia from comment #2)
> I'm not sure what's the "problem". Is the default type of vNIC supposed to
> be determined by osinfo? If so, I don't think this was ever implemented. If
> you create a new vNIC through the VM/interfaces subtab, you'll see that the
> default choice there is VirtIO as well, the only difference is that there's
> no widget to change that in the new VM dialog.

Its not only a default but rather the set of available values is determined by osinfo. so in this use-case virtio shouldn't be there at all

for some OS admin can determine virtio (PV) shouldn't be available

new vm dialog has this which should be fixed:

    protected void initSelectedType() {
        getNicType().setSelectedItem(AsyncDataProvider.getDefaultNicType());
    }
Comment 4 Martin Pavlik 2014-04-25 04:41:38 EDT
verified av7

VM NIC type is e1000
Comment 5 Itamar Heim 2014-06-12 10:11:39 EDT
Closing as part of 3.4.0

Note You need to log in before you can comment on or make changes to this bug.