Bug 996095 - Incorrect commands for deploying application on multiple servers
Incorrect commands for deploying application on multiple servers
Status: CLOSED CURRENTRELEASE
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: Documentation (Show other bugs)
6.1.1
Unspecified Unspecified
unspecified Severity high
: GA
: EAP 6.3.0
Assigned To: Misha H. Ali
Russell Dickenson
: Documentation, EasyFix, Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-12 08:01 EDT by Richard Janík
Modified: 2014-08-14 11:23 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-28 11:41:33 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Richard Janík 2013-08-12 08:01:13 EDT
Document URL: 

https://access.redhat.com/site/documentation/en-US/JBoss_Enterprise_Application_Platform/6.1/html-single/Development_Guide/index.html#chap-CDI

Section Number and Name: 

8.4. Implement an HA Singleton
  --> Procedure 8.3. Implement an HA Singleton Service
  --> 3. Deploy the application to the servers

Describe the issue: 

Documentation provides commands
    mvn clean install jboss-as:deploy
and
    mvn clean package jboss-as:deploy -Ddeploy.hostname=localhost -Ddeploy.port=10099
for deploying an application on two servers. The second command is wrong, since argument -Ddeploy.port=10099 is being ignored by jboss-as plugin.

Suggestions for improvement: 

Substitute -Ddeploy.port=10099 with -Djboss-as.port=10099 as is shown in jboss-as-quickstarts: https://github.com/jboss-jdf/jboss-as-quickstart/tree/master/cluster-ha-singleton (Build and deploy the quickstart) and in the documentation of the plugin itself: https://docs.jboss.org/jbossas/7/plugins/maven/latest/deploy-mojo.html.

The second command will then look like this:
    mvn clean package jboss-as:deploy -Ddeploy.hostname=localhost -Djboss-as.port=10099
Comment 1 Misha H. Ali 2014-02-04 20:44:18 EST
Fixed final command (step 3). Waiting of rebuild to provide a verification link.
Comment 3 Scott Mumford 2014-02-26 00:13:56 EST
Moving to ON_QA.

The changes should be available for review on the documentation stage within an hour or so from this comment.

http://documentation-devel.engineering.redhat.com/site/documentation/en-US/JBoss_Enterprise_Application_Platform/
Comment 4 Scott Mumford 2014-02-26 00:15:51 EST
Moving to ON_QA.

The changes should be available for review on the documentation stage within an hour or so from this comment.

http://documentation-devel.engineering.redhat.com/site/documentation/en-US/JBoss_Enterprise_Application_Platform/

Note You need to log in before you can comment on or make changes to this bug.