Bug 996102 - [AMQP 1.0] swigged python test failures over AMQP 1.0 on RHEL5
[AMQP 1.0] swigged python test failures over AMQP 1.0 on RHEL5
Status: CLOSED NOTABUG
Product: Red Hat Enterprise MRG
Classification: Red Hat
Component: qpid-cpp (Show other bugs)
Development
Unspecified Linux
low Severity unspecified
: 3.0
: ---
Assigned To: Gordon Sim
MRG Quality Engineering
: OtherQA
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-12 08:14 EDT by Gordon Sim
Modified: 2013-08-14 09:57 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-14 06:16:20 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Apache JIRA QPID-5051 None None None Never

  None (edit)
Description Gordon Sim 2013-08-12 08:14:58 EDT
Description of problem:

Running the AMQP 1.0 based swigged python tests results in two errors on RHEL5. One error is caused by the test using a version of the enumerate() function that is not available on the version of python available on RHEL5. The other is due to symbol visibility issues for the qpid::types::InvalidConversion exception type.

Version-Release number of selected component (if applicable):

qpid-0.24rc1

How reproducible:

100%

Steps to Reproduce:
1. for a qpid svn checkout make && make test (or make && ctest -R swig_python_tests to avoid running all other tests)

Actual results:

Get two failures

Expected results:

All tests pass

Additional info:

Only an issue on RHEL5
Comment 1 Gordon Sim 2013-08-12 08:15:45 EDT
Fixed upstream: https://svn.apache.org/r1511483
Comment 3 Gordon Sim 2013-08-14 06:16:20 EDT
I raised this issue in error. The swig tests are not actually on the 0.22-mrg branch, so porting a fix for them doesn't make sense. Moving to CLOSED, NOTABUG.

Note You need to log in before you can comment on or make changes to this bug.