This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 996145 - Server fails to deploy RTGov, DTGov after installing S-RAMP into SOA 6
Server fails to deploy RTGov, DTGov after installing S-RAMP into SOA 6
Status: CLOSED CURRENTRELEASE
Product: JBoss Fuse Service Works 6
Classification: JBoss
Component: Installer (Show other bugs)
6.0.0 GA
Unspecified Unspecified
unspecified Severity urgent
: ER3
: ---
Assigned To: Thomas Hauser
Len DiMaggio
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-12 09:58 EDT by Stefan Bunciak
Modified: 2014-02-06 10:32 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Server log (55.08 KB, text/x-log)
2013-08-12 09:58 EDT, Stefan Bunciak
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Bugzilla 993272 None None None Never

  None (edit)
Description Stefan Bunciak 2013-08-12 09:58:35 EDT
Created attachment 785694 [details]
Server log

Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Download installer for both SOA & S-RAMP 6.0.0.ER1 (from http://dev138.mw.lab.eng.bos.redhat.com/candidate/soa-6.0.0.ER1/)
2. Install SOA using the installer
3. Install S-RAMP using the installer on the top of SOA installed in STEP #2

Actual results:

* Extracts from server log after start-up:

15:19:57,886 ERROR [org.jboss.msc.service.fail] (MSC service thread 1-5) MSC000001: Failed to start service jboss.deployment.unit."overlord-rtgov.war".PARSE: org.jboss.msc.service.StartException in service jboss.deployment.unit."overlord-rtgov.war".PARSE: JBAS018733: Failed to process phase PARSE of deployment "overlord-rtgov.war"

Services which failed to start:      service jboss.deployment.unit."overlord-rtgov.war".PARSE: org.jboss.msc.service.StartException in service jboss.deployment.unit."overlord-rtgov.war".PARSE: JBAS018733: Failed to process phase PARSE of deployment "overlord-rtgov.war"


ERROR [org.jboss.as] (Controller Boot Thread) JBAS015875: JBoss Red Hat JBoss Fuse Service Works 6.0.0.ER1-redhat-1 (AS 7.2.0.Final-redhat-8) started (with errors) in 14280ms - Started 782 of 1041 services (164 services failed or missing dependencies, 92 services are passive or on-demand)


Expected results:

* Installer copes with the configurations and DTGov is deployed successfully out-of-the box and the server starts without failures/errors

Additional info:
 
* S-RAMP ui is deployed but rtgov/dtgov are not
Comment 1 Thomas Hauser 2013-08-13 10:34:50 EDT
These errors occur while using the zips as well:

Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:
Always 

Steps to Reproduce:
1. Download soa and sramp zips from http://dev138.mw.lab.eng.bos.redhat.com/candidate/soa-6.0.0.ER1/
2. Unzip SOA on top of EAP 6.1.0.GA
3. Unzip S-RAMP onto this SOA unzip

Actual results:

* Extracts from server log after start-up:

10:29:45,974 ERROR [org.jboss.msc.service.fail] (MSC service thread 1-2) MSC000001: Failed to start service jboss.deployment.unit."overlord-rtgov.war".PARSE: org.jboss.msc.service.StartException in service jboss.deployment.unit."overlord-rtgov.war".PARSE: JBAS018733: Failed to process phase PARSE of deployment "overlord-rtgov.war"

10:29:47,620 ERROR [org.jboss.msc.service.fail] (MSC service thread 1-5) MSC000001: Failed to start service jboss.module.service."deployment.switchyard-bpel-console.war".main: org.jboss.msc.service.StartException in service jboss.module.service."deployment.switchyard-bpel-console.war".main: JBAS018759: Failed to load module: deployment.switchyard-bpel-console.war:main

10:29:48,244 ERROR [org.jboss.msc.service.fail] (MSC service thread 1-6) MSC000001: Failed to start service jboss.module.service."deployment.switchyard-bpel-console-server.war".main: org.jboss.msc.service.StartException in service jboss.module.service."deployment.switchyard-bpel-console-server.war".main: JBAS018759: Failed to load module: deployment.switchyard-bpel-console-server.war:main

10:30:01,546 ERROR [org.jboss.as] (Controller Boot Thread) JBAS015875: JBoss Red Hat JBoss SRAMP 6.0.0.ER1-redhat-1 (AS 7.2.0.Final-redhat-8) started (with errors) in 26287ms - Started 529 of 738 services (124 services failed or missing dependencies, 83 services are passive or on-demand)

Expected results:

* Unzipping SOA onto EAP-6.1.0 and S-RAMP on top of that works correctly.


In light of these errors, even with no additional configuration options selected in the installer (resultant directories are identical with installations done by simple unzipping), I would say it's a problem with the zips themselves.
Comment 2 Stefan Bunciak 2013-08-14 06:43:46 EDT
I confirm that this is reproducible also with the zips as well, as stated in https://bugzilla.redhat.com/show_bug.cgi?id=993272. That is quite expected behaviour since by extracting contents of the zips you are explicitly overwriting the server configuration, but the installer should cope with this and create a usable configuration for SOA6+S-RAMP+DTGov+RTGov.
Comment 3 trev 2013-08-14 10:10:49 EDT
Without a spec of what this usable configuration should be, this is rather difficult to achieve. Who can provide this spec?
Comment 4 Stefan Bunciak 2013-08-16 06:08:18 EDT
I believe that such configuration spec should already exist, since there is a new installer comming to ER2:

One Installer - does not include EAP 6.1 - allows users to install:
   - SOA/SwitchYard server
   - RTGov server -OR- RTGov client (mututally exclusive)
   - DTGov server (if this is selected, then S-RAMP is automatically installed)
   - S-RAMP
Comment 5 Thomas Hauser 2013-08-26 16:53:56 EDT
This issue should be revisited when it's time for ER2.
Comment 6 Thomas Hauser 2013-09-20 15:47:10 EDT
The configuration should all mesh successfully.
Comment 7 Stefan Bunciak 2013-09-23 05:32:00 EDT
Verified with S-RAMP 6.0.0.ER3. All 3 SOA Governance components are deployed.

Note You need to log in before you can comment on or make changes to this bug.