Bug 996163 - [abrt] httpd-2.4.4-6.fc19: apr_getnameinfo: Process /usr/sbin/httpd was killed by signal 11 (SIGSEGV)
[abrt] httpd-2.4.4-6.fc19: apr_getnameinfo: Process /usr/sbin/httpd was kille...
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: httpd (Show other bugs)
19
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Joe Orton
Fedora Extras Quality Assurance
abrt_hash:537efa5e174a1f8fbc002a8bc83...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-12 10:32 EDT by William Penton
Modified: 2013-08-26 11:17 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-26 11:17:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (21.41 KB, text/plain)
2013-08-12 10:32 EDT, William Penton
no flags Details
File: cgroup (156 bytes, text/plain)
2013-08-12 10:32 EDT, William Penton
no flags Details
File: core_backtrace (1.53 KB, text/plain)
2013-08-12 10:32 EDT, William Penton
no flags Details
File: dso_list (10.13 KB, text/plain)
2013-08-12 10:32 EDT, William Penton
no flags Details
File: environ (153 bytes, text/plain)
2013-08-12 10:32 EDT, William Penton
no flags Details
File: limits (1.29 KB, text/plain)
2013-08-12 10:32 EDT, William Penton
no flags Details
File: maps (49.37 KB, text/plain)
2013-08-12 10:32 EDT, William Penton
no flags Details
File: open_fds (169 bytes, text/plain)
2013-08-12 10:32 EDT, William Penton
no flags Details
File: proc_pid_status (890 bytes, text/plain)
2013-08-12 10:32 EDT, William Penton
no flags Details
File: var_log_messages (394 bytes, text/plain)
2013-08-12 10:32 EDT, William Penton
no flags Details

  None (edit)
Description William Penton 2013-08-12 10:32:25 EDT
Version-Release number of selected component:
httpd-2.4.4-6.fc19

Additional info:
reporter:       libreport-2.1.6
backtrace_rating: 4
cmdline:        /usr/sbin/httpd -DFOREGROUND
crash_function: apr_getnameinfo
executable:     /usr/sbin/httpd
kernel:         3.10.4-300.fc19.x86_64
runlevel:       N 5
uid:            0

Truncated backtrace:
Thread no. 1 (3 frames)
 #0 apr_getnameinfo at network_io/unix/sockaddr.c:621
 #1 ap_get_local_host at util.c:2093
 #2 ap_fini_vhost_config at vhost.c:565
Comment 1 William Penton 2013-08-12 10:32:29 EDT
Created attachment 785719 [details]
File: backtrace
Comment 2 William Penton 2013-08-12 10:32:32 EDT
Created attachment 785721 [details]
File: cgroup
Comment 3 William Penton 2013-08-12 10:32:35 EDT
Created attachment 785723 [details]
File: core_backtrace
Comment 4 William Penton 2013-08-12 10:32:38 EDT
Created attachment 785725 [details]
File: dso_list
Comment 5 William Penton 2013-08-12 10:32:41 EDT
Created attachment 785726 [details]
File: environ
Comment 6 William Penton 2013-08-12 10:32:44 EDT
Created attachment 785728 [details]
File: limits
Comment 7 William Penton 2013-08-12 10:32:47 EDT
Created attachment 785730 [details]
File: maps
Comment 8 William Penton 2013-08-12 10:32:51 EDT
Created attachment 785732 [details]
File: open_fds
Comment 9 William Penton 2013-08-12 10:32:54 EDT
Created attachment 785733 [details]
File: proc_pid_status
Comment 10 William Penton 2013-08-12 10:32:59 EDT
Created attachment 785734 [details]
File: var_log_messages
Comment 11 Steven Oliphant 2013-08-26 09:18:30 EDT
I have no idea what caused the abort - Apache has not been configured and is in the fresh install state 

reporter:       libreport-2.1.6
backtrace_rating: 4
cmdline:        /usr/sbin/httpd -DFOREGROUND
crash_function: apr_getnameinfo
executable:     /usr/sbin/httpd
kernel:         3.10.6-200.fc19.i686.PAE
package:        httpd-2.4.6-2.fc19
reason:         Process /usr/sbin/httpd was killed by signal 11 (SIGSEGV)
runlevel:       N 5
uid:            0
Comment 12 Jan Kaluža 2013-08-26 11:17:09 EDT
This looks like the same bug as Bug 958652, which should be fixed already in glibc and also workarounded in apr-1.4.7. According to DSO attachment, you have apr-1.4.6, so updating to newer APR should fix this bug.

I'm closing this one as WORKSFORME, because the fix is already in latest F19, you just don't have that update ;). Feel free to reopen if this happens again with latest APR package.

Note You need to log in before you can comment on or make changes to this bug.