Bug 996217 - texlive-latex cannot be installed
texlive-latex cannot be installed
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: texlive (Show other bugs)
7.0
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Ngo Than
BaseOS QE Security Team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-12 12:59 EDT by Matěj Cepl
Modified: 2013-08-13 06:00 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-13 06:00:37 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matěj Cepl 2013-08-12 12:59:25 EDT
Description of problem:
wycliff:~# yum install texlive-latex
Loaded plugins: auto-update-debuginfo, langpacks, product-id, refresh-packagekit,
              : subscription-manager
This system is not registered to Red Hat Subscription Management. You can use subscription-manager to register.
Resolving Dependencies
--> Running transaction check
---> Package texlive-latex.noarch 2:svn27907.0-25.1.el7 will be installed
--> Processing Dependency: tex-luatex for package: 2:texlive-latex-svn27907.0-25.1.el7.noarch
--> Processing Dependency: tex-pdftex for package: 2:texlive-latex-svn27907.0-25.1.el7.noarch
--> Processing Dependency: tex(hyperref.sty) for package: 2:texlive-latex-svn27907.0-25.1.el7.noarch
--> Running transaction check
---> Package texlive-hyperref.noarch 2:svn28213.6.83m-25.1.el7 will be installed
--> Processing Dependency: tex(kvoptions.sty) for package: 2:texlive-hyperref-svn28213.6.83m-25.1.el7.noarch
--> Processing Dependency: tex(kvsetkeys.sty) for package: 2:texlive-hyperref-svn28213.6.83m-25.1.el7.noarch
--> Processing Dependency: tex(ltxcmds.sty) for package: 2:texlive-hyperref-svn28213.6.83m-25.1.el7.noarch
--> Processing Dependency: tex(rerunfilecheck.sty) for package: 2:texlive-hyperref-svn28213.6.83m-25.1.el7.noarch
--> Processing Dependency: tex(hobsub-hyperref.sty) for package: 2:texlive-hyperref-svn28213.6.83m-25.1.el7.noarch
--> Processing Dependency: tex(ifpdf.sty) for package: 2:texlive-hyperref-svn28213.6.83m-25.1.el7.noarch
--> Processing Dependency: tex(pdftexcmds.sty) for package: 2:texlive-hyperref-svn28213.6.83m-25.1.el7.noarch
--> Processing Dependency: tex(infwarerr.sty) for package: 2:texlive-hyperref-svn28213.6.83m-25.1.el7.noarch
--> Processing Dependency: tex(kvdefinekeys.sty) for package: 2:texlive-hyperref-svn28213.6.83m-25.1.el7.noarch
--> Processing Dependency: tex(pdfescape.sty) for package: 2:texlive-hyperref-svn28213.6.83m-25.1.el7.noarch
--> Processing Dependency: tex(ifvtex.sty) for package: 2:texlive-hyperref-svn28213.6.83m-25.1.el7.noarch
--> Processing Dependency: tex(hycolor.sty) for package: 2:texlive-hyperref-svn28213.6.83m-25.1.el7.noarch
--> Processing Dependency: tex(letltxmacro.sty) for package: 2:texlive-hyperref-svn28213.6.83m-25.1.el7.noarch
--> Processing Dependency: tex(auxhook.sty) for package: 2:texlive-hyperref-svn28213.6.83m-25.1.el7.noarch
--> Processing Dependency: tex(intcalc.sty) for package: 2:texlive-hyperref-svn28213.6.83m-25.1.el7.noarch
--> Processing Dependency: tex(etexcmds.sty) for package: 2:texlive-hyperref-svn28213.6.83m-25.1.el7.noarch
--> Processing Dependency: tex(memhfixc.sty) for package: 2:texlive-hyperref-svn28213.6.83m-25.1.el7.noarch
--> Processing Dependency: tex(stringenc.sty) for package: 2:texlive-hyperref-svn28213.6.83m-25.1.el7.noarch
--> Processing Dependency: tex(bitset.sty) for package: 2:texlive-hyperref-svn28213.6.83m-25.1.el7.noarch
--> Processing Dependency: tex(atbegshi.sty) for package: 2:texlive-hyperref-svn28213.6.83m-25.1.el7.noarch
--> Processing Dependency: tex(refcount.sty) for package: 2:texlive-hyperref-svn28213.6.83m-25.1.el7.noarch
--> Processing Dependency: tex(gettitlestring.sty) for package: 2:texlive-hyperref-svn28213.6.83m-25.1.el7.noarch
---> Package texlive-luatex.noarch 2:svn26689.0.70.1-25.1.el7 will be installed
--> Processing Dependency: texlive-luatex-bin for package: 2:texlive-luatex-svn26689.0.70.1-25.1.el7.noarch
---> Package texlive-pdftex.noarch 2:svn29585.1.40.11-25.1.el7 will be installed
--> Processing Dependency: texlive-pdftex-bin for package: 2:texlive-pdftex-svn29585.1.40.11-25.1.el7.noarch
--> Running transaction check
---> Package texlive-luatex-bin.x86_64 2:svn26912.0-25.1.20130427_r30134.el7 will be installed
--> Processing Dependency: texlive-kpathsea-lib = 2:2012-25.1.20130427_r30134.el7 for package: 2:texlive-luatex-bin-svn26912.0-25.1.20130427_r30134.el7.x86_64
--> Processing Dependency: libzzip-0.so.13()(64bit) for package: 2:texlive-luatex-bin-svn26912.0-25.1.20130427_r30134.el7.x86_64
---> Package texlive-memoir.noarch 2:svn21638.3.6j_patch_6.0g-25.1.el7 will be installed
---> Package texlive-oberdiek.noarch 2:svn26725.0-25.1.el7 will be installed
--> Processing Dependency: tex(fontspec.sty) for package: 2:texlive-oberdiek-svn26725.0-25.1.el7.noarch
--> Processing Dependency: tex(unicode-math.sty) for package: 2:texlive-oberdiek-svn26725.0-25.1.el7.noarch
--> Processing Dependency: tex(listings.sty) for package: 2:texlive-oberdiek-svn26725.0-25.1.el7.noarch
--> Processing Dependency: tex(tikz.sty) for package: 2:texlive-oberdiek-svn26725.0-25.1.el7.noarch
--> Processing Dependency: tex(everyshi.sty) for package: 2:texlive-oberdiek-svn26725.0-25.1.el7.noarch
---> Package texlive-pdftex-bin.x86_64 2:svn27321.0-25.1.20130427_r30134.el7 will be installed
--> Running transaction check
---> Package texlive-fontspec.noarch 2:svn29412.v2.3a-25.1.el7 will be installed
--> Processing Dependency: tex(xunicode.sty) for package: 2:texlive-fontspec-svn29412.v2.3a-25.1.el7.noarch
--> Processing Dependency: tex(expl3.sty) for package: 2:texlive-fontspec-svn29412.v2.3a-25.1.el7.noarch
--> Processing Dependency: tex(xparse.sty) for package: 2:texlive-fontspec-svn29412.v2.3a-25.1.el7.noarch
--> Processing Dependency: tex(luaotfload.sty) for package: 2:texlive-fontspec-svn29412.v2.3a-25.1.el7.noarch
---> Package texlive-kpathsea-lib.i686 2:2012-25.1.20130427_r30134.el7 will be installed
---> Package texlive-listings.noarch 2:svn15878.1.4-25.1.el7 will be installed
--> Processing Dependency: tex(fancyvrb.sty) for package: 2:texlive-listings-svn15878.1.4-25.1.el7.noarch
--> Processing Dependency: tex(algorithmic.sty) for package: 2:texlive-listings-svn15878.1.4-25.1.el7.noarch
---> Package texlive-ms.noarch 2:svn24467.0-25.1.el7 will be installed
--> Processing Dependency: tex(scrtime.sty) for package: 2:texlive-ms-svn24467.0-25.1.el7.noarch
---> Package texlive-pgf.noarch 2:svn22614.2.10-25.1.el7 will be installed
--> Processing Dependency: tex(xcolor.sty) for package: 2:texlive-pgf-svn22614.2.10-25.1.el7.noarch
---> Package texlive-unicode-math.noarch 2:svn29413.0.7d-25.1.el7 will be installed
--> Processing Dependency: tex(lualatex-math.sty) for package: 2:texlive-unicode-math-svn29413.0.7d-25.1.el7.noarch
--> Processing Dependency: tex(luatexbase.sty) for package: 2:texlive-unicode-math-svn29413.0.7d-25.1.el7.noarch
--> Processing Dependency: tex(filehook.sty) for package: 2:texlive-unicode-math-svn29413.0.7d-25.1.el7.noarch
---> Package zziplib.x86_64 0:0.13.62-3.el7 will be installed
--> Running transaction check
---> Package texlive-algorithms.noarch 2:svn15878.0.1-25.1.el7 will be installed
---> Package texlive-fancyvrb.noarch 2:svn18492.2.8-25.1.el7 will be installed
--> Processing Dependency: tex(pstricks.sty) for package: 2:texlive-fancyvrb-svn18492.2.8-25.1.el7.noarch
---> Package texlive-filehook.noarch 2:svn24280.0.5d-25.1.el7 will be installed
--> Processing Dependency: tex(currfile.sty) for package: 2:texlive-filehook-svn24280.0.5d-25.1.el7.noarch
---> Package texlive-koma-script.noarch 2:svn27255.3.11b-25.1.el7 will be installed
--> Processing Dependency: tex(geometry.sty) for package: 2:texlive-koma-script-svn27255.3.11b-25.1.el7.noarch
---> Package texlive-l3kernel.noarch 2:svn29409.SVN_4469-25.1.el7 will be installed
---> Package texlive-l3packages.noarch 2:svn29361.SVN_4467-25.1.el7 will be installed
---> Package texlive-lualatex-math.noarch 2:svn29346.1.2-25.1.el7 will be installed
---> Package texlive-luaotfload.noarch 2:svn26718.1.26-25.1.el7 will be installed
---> Package texlive-luatexbase.noarch 2:svn22560.0.31-25.1.el7 will be installed
---> Package texlive-xcolor.noarch 2:svn15878.2.11-25.1.el7 will be installed
---> Package texlive-xunicode.noarch 2:svn23897.0.981-25.1.el7 will be installed
--> Processing Dependency: tex(t3enc.def) for package: 2:texlive-xunicode-svn23897.0.981-25.1.el7.noarch
--> Running transaction check
---> Package texlive-currfile.noarch 2:svn29012.0.7b-25.1.el7 will be installed
---> Package texlive-geometry.noarch 2:svn19716.5.6-25.1.el7 will be installed
---> Package texlive-pstricks.noarch 2:svn29678.2.39-25.1.el7 will be installed
--> Processing Dependency: tex(pst-plot.sty) for package: 2:texlive-pstricks-svn29678.2.39-25.1.el7.noarch
--> Processing Dependency: tex(pst-node.sty) for package: 2:texlive-pstricks-svn29678.2.39-25.1.el7.noarch
--> Processing Dependency: tex(pst-tree.sty) for package: 2:texlive-pstricks-svn29678.2.39-25.1.el7.noarch
--> Processing Dependency: tex(pst-grad.sty) for package: 2:texlive-pstricks-svn29678.2.39-25.1.el7.noarch
--> Processing Dependency: tex(pst-coil.sty) for package: 2:texlive-pstricks-svn29678.2.39-25.1.el7.noarch
--> Processing Dependency: tex(pst-text.sty) for package: 2:texlive-pstricks-svn29678.2.39-25.1.el7.noarch
--> Processing Dependency: tex(pst-3d.sty) for package: 2:texlive-pstricks-svn29678.2.39-25.1.el7.noarch
--> Processing Dependency: tex(pst-eps.sty) for package: 2:texlive-pstricks-svn29678.2.39-25.1.el7.noarch
--> Processing Dependency: tex(pst-fill.sty) for package: 2:texlive-pstricks-svn29678.2.39-25.1.el7.noarch
--> Processing Dependency: tex(pstricks-add.sty) for package: 2:texlive-pstricks-svn29678.2.39-25.1.el7.noarch
--> Processing Dependency: tex(bera.sty) for package: 2:texlive-pstricks-svn29678.2.39-25.1.el7.noarch
--> Processing Dependency: tex(eso-pic.sty) for package: 2:texlive-pstricks-svn29678.2.39-25.1.el7.noarch
--> Processing Dependency: tex(showexpl.sty) for package: 2:texlive-pstricks-svn29678.2.39-25.1.el7.noarch
--> Processing Dependency: tex(breakurl.sty) for package: 2:texlive-pstricks-svn29678.2.39-25.1.el7.noarch
---> Package texlive-tipa.noarch 2:svn29349.1.3-25.1.el7 will be installed
--> Running transaction check
---> Package texlive-bera.noarch 2:svn20031.0-25.1.el7 will be installed
---> Package texlive-breakurl.noarch 2:svn15878.1.30-25.1.el7 will be installed
---> Package texlive-eso-pic.noarch 2:svn21515.2.0c-25.1.el7 will be installed
---> Package texlive-pst-3d.noarch 2:svn17257.1.10-25.1.el7 will be installed
---> Package texlive-pst-coil.noarch 2:svn24020.1.06-25.1.el7 will be installed
---> Package texlive-pst-eps.noarch 2:svn15878.1.0-25.1.el7 will be installed
---> Package texlive-pst-fill.noarch 2:svn15878.1.01-25.1.el7 will be installed
---> Package texlive-pst-grad.noarch 2:svn15878.1.06-25.1.el7 will be installed
---> Package texlive-pst-node.noarch 2:svn27799.1.25-25.1.el7 will be installed
---> Package texlive-pst-plot.noarch 2:svn28729.1.44-25.1.el7 will be installed
---> Package texlive-pst-text.noarch 2:svn15878.1.00-25.1.el7 will be installed
---> Package texlive-pst-tree.noarch 2:svn24142.1.12-25.1.el7 will be installed
---> Package texlive-pstricks-add.noarch 2:svn28750.3.59-25.1.el7 will be installed
---> Package texlive-showexpl.noarch 2:svn27790.v0.3j-25.1.el7 will be installed
--> Processing Dependency: tex(attachfile.sty) for package: 2:texlive-showexpl-svn27790.v0.3j-25.1.el7.noarch
--> Running transaction check
---> Package texlive-attachfile.noarch 2:svn21866.v1.5b-25.1.el7 will be installed
--> Finished Dependency Resolution
--> Finding unneeded leftover dependencies
Found and removing 0 unneeded dependencies
Error:  Multilib version problems found. This often means that the root
       cause is something else and multilib version checking is just
       pointing out that there is a problem. Eg.:
       
         1. You have an upgrade for texlive-kpathsea-lib which is missing some
            dependency that another package requires. Yum is trying to
            solve this by installing an older version of texlive-kpathsea-lib of the
            different architecture. If you exclude the bad architecture
            yum will tell you what the root cause is (which package
            requires what). You can try redoing the upgrade with
            --exclude texlive-kpathsea-lib.otherarch ... this should give you an error
            message showing the root cause of the problem.
       
         2. You have multiple architectures of texlive-kpathsea-lib installed, but
            yum can only see an upgrade for one of those architectures.
            If you don't want/need both architectures anymore then you
            can remove the one with the missing update and everything
            will work.
       
         3. You have duplicate versions of texlive-kpathsea-lib installed already.
            You can use "yum check" to get yum show these errors.
       
       ...you can also use --setopt=protected_multilib=false to remove
       this checking, however this is almost never the correct thing to
       do as something else is very likely to go wrong (often causing
       much more problems).
       
       Protected multilib versions: 2:texlive-kpathsea-lib-2012-25.1.20130427_r30134.el7.i686 != 3:texlive-kpathsea-lib-2013-0.1.20130608_r30832.el7.x86_64
wycliff:~# 

Possibly a duplicate of bug 881261?
Comment 1 Matěj Cepl 2013-08-12 13:06:35 EDT
The same what goes here for texlive-luatex-bin goes texlive-pdftex-bin
Comment 3 Ngo Than 2013-08-13 06:00:37 EDT
(In reply to Matěj Cepl from comment #0)
> Description of problem:
> wycliff:~# yum install texlive-latex
>        
>        Protected multilib versions:
> 2:texlive-kpathsea-lib-2012-25.1.20130427_r30134.el7.i686 !=
> 3:texlive-kpathsea-lib-2013-0.1.20130608_r30832.el7.x86_64
> wycliff:~# 
> 

the error show me that you have installed texlive version 2013-0.1.20130608_r30832
which we don't have in rhel7. The latest rhel7 texlive version is 2012-25.1.20130427_r30134.

Please remove your own texlive version and install the correct on from rhel7.


> Possibly a duplicate of bug 881261?

i don't think so.

Note You need to log in before you can comment on or make changes to this bug.