Bug 996218 - Problem with cassandra during upgrading RHQ server from version 4.8.0 to 4.9.0.
Problem with cassandra during upgrading RHQ server from version 4.8.0 to 4.9.0.
Status: CLOSED NOTABUG
Product: JBoss Operations Network
Classification: JBoss
Component: Upgrade (Show other bugs)
JON 3.2
Unspecified Unspecified
unspecified Severity unspecified
: ER01
: JON 3.2.0
Assigned To: John Sanda
Mike Foley
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-12 13:02 EDT by jvlasak
Modified: 2013-11-03 20:39 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-05 14:54:11 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Log from upgrading process. (4.31 KB, text/plain)
2013-08-12 13:02 EDT, jvlasak
no flags Details

  None (edit)
Description jvlasak 2013-08-12 13:02:15 EDT
Created attachment 785779 [details]
Log from upgrading process.

Description of problem:
There is thrown cassandra exception during upgrading RHQ server from version 4.8.0 to 4.9.0.

Version-Release number of selected component (if applicable):


How reproducible:
always

Steps to Reproduce:
1.Install RHQ server and agent in version 4.8.0 () and run them (consider server's directory /home/hudson/rhq-server-4.8.0 and agent's /home/hudson/rhq-agent).
2.Login into the server application and click on Inventory item.
3.In Resources section click on Discovery Queue and import all displayed resources.
4.Download the last stable RHQ server 4.9.0 (http://jenkins.mw.lab.eng.bos.redhat.com/hudson/view/RHQ/job/rhq-master/2508/artifact/rhq/modules/enterprise/server/appserver/target/rhq-server-4.9.0-SNAPSHOT.zip), unzip it and go to its bin directory.
5.Then as root execute command: ./rhqctl upgrade --from-server-dir /home/hudson/rhq-server-4.8.0 --from-agent-dir /home/hudson/rhq-agent.

Actual results:
There is thrown cassandra exception during upgrading process (see log file in attachments).
RHQ server and agent are not updated to 4.9.0.
Storage node is not installed.
Platform, agent and all its childs are not available.

Expected results:
RHQ server and agent are updated to 4.9.0.
Storage node is installed.
Platform, agent and all its childs are available.

Additional info:
Comment 2 Heiko W. Rupp 2013-08-16 12:35:17 EDT
I don't think this is relevant for JON 3.2, as JON users will upgrade from JON 3.1 or earlier, that had no Cassandra support.

It is / may be relevant for RHQ users though.

John, could you investigate if that is an issue for RHQ 4.9 ?
Comment 3 John Sanda 2013-08-18 21:27:33 EDT
Heiko you are correct about JON 3.2. Because of removing the native library support in 4.9, 4.8 users will have to go through an extra step. That extra step does not apply to JON 3.2 upgrades.

jvlasak, you need to run the rhq48-storage-patch.sh[1] script prior to upgrading. Please review the instructions included in the script and try the upgrade again.

[1] https://git.fedorahosted.org/cgit/rhq/rhq.git/tree/etc/scripts/rhq48-storage-patch/rhq48-storage-patch.sh
Comment 4 Mike Foley 2013-09-05 14:54:11 EDT
not a valid test for JON 3.2.  QE will be performing extensive upgrade tests relevant to JON.

Note You need to log in before you can comment on or make changes to this bug.