Bug 996275 - [RFE] libdvdread 4.2.0 and libdvdnav 4.2.0 - solves issues with NEW DVDs
[RFE] libdvdread 4.2.0 and libdvdnav 4.2.0 - solves issues with NEW DVDs
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: libdvdread (Show other bugs)
6.6
All Linux
unspecified Severity unspecified
: rc
: ---
Assigned To: Jiri Kulda
Desktop QE
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-12 16:09 EDT by andrew
Modified: 2016-07-20 07:55 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-07-20 07:55:53 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description andrew 2013-08-12 16:09:43 EDT
Description of problem:

Versions below 4.2 of both libs are consistently causing crashes across multiple products - dvdbackup, vlc etc. when used against relatively _new_ DVD disks.

I personally ran into the issue with the crash of vlc which reported:
"libdvdread: Using libdvdcss version 1.2.10 for DVD access
Please send bug report - no VTS_TMAPT". Same message was received when i ran "dvdbackup"

Version-Release number of selected component (if applicable):
4.1.X

How reproducible:
i tried two new ( after 2011 ) DVD and got 100% crashes. Older (<2008 ) work fine. i don't have any other new DVD i can try. But this issue is confirmed based on the amount of posts across other products and OS.

Steps to Reproduce:
1. plug a new DVD ( i used "Metamorphosis by Tracy Anderson method" DVD
2. attempt to take a backup with dvdbackup: dvdbackup -M ...
3. observe "libdvdread: Using libdvdcss version 1.2.10 for DVD access
Please send bug report - no VTS_TMAPT" message and crash of the dvdbackup
4. attempts to utilize vlc to convert the dvd into avi file lead to over 24 hours continues processing on AMD 4core with >10GB output file. Obviously this is incorrect.

Actual results:
crash with ""libdvdread: Using libdvdcss version 1.2.10 for DVD access
Please send bug report - no VTS_TMAPT"" message

Expected results:
normal exit of the main program

Additional info:
upgrade of libs to the latest available from the site (http://dvdnav.mplayerhq.hu/) version (4.2 ) solves this issue.
Comment 2 RHEL Product and Program Management 2013-10-13 19:16:22 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unable to address this
request at this time.

Red Hat invites you to ask your support representative to
propose this request, if appropriate, in the next release of
Red Hat Enterprise Linux.
Comment 3 andrew 2014-08-26 12:18:32 EDT
Please include into the next release
Comment 4 Jiri Kulda 2016-07-20 03:43:01 EDT
Hi,
as a new libdvdread maintainer I apologize for this late response. 

This bug is fixed in RHEL-7 and RHEL-6 is in production phase 2 so we cannot adding new features into RHEL-6. On the other hand If you really want this bug to be fixed then please try it through customer portal. 
Thank you for understanding.
Jiri

Note You need to log in before you can comment on or make changes to this bug.