Bug 9963 - "end" and "home" key characteristics changed.
"end" and "home" key characteristics changed.
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: vim (Show other bugs)
6.2
All Linux
medium Severity medium
: ---
: ---
Assigned To: Preston Brown
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-03-04 12:26 EST by Dale Lovelace
Modified: 2008-05-01 11:37 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-05-08 10:15:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dale Lovelace 2000-03-04 12:26:20 EST
In Red Hat Linux 6.1 both the "home" and "end" keys would take you to
either the beginning or end of the line. In vim-*-5.6-10 the behavior of
these keys has changed. These tests were performed as user "root" with no
.vimrc.

/bin/vi (vim-minimal)
  At The Console:
    The "home" key behaves as excpected.
    The "end" key changes the case of the character the cursor is on.

  In X:
    Both the "home" and "end" key works as expected.

/usr/bin/vim (from vim-enhanced)
  At The Console:
    Both the "home" and "end keys change the case of the character the
	cursor is on.

  In X:
    Both the "home" and "end keys change the case of the character the
	cursor is on.
Comment 1 Cristian Gafton 2000-03-04 17:22:59 EST
Preston, can you please handle this asap? Thanks,
Comment 2 Bernhard Rosenkraenzer 2000-03-05 04:23:59 EST
I can't reproduce this problem on the console; must be related to the
recent xterm changes. :/
And what's worse, over the weekend I'm stuck with a 486SX notebook
that can't run X so I can't do anything about it until tomorrow.
Comment 3 Cristian Gafton 2000-03-06 16:11:59 EST
Preston, this is yours
Comment 4 Preston Brown 2000-05-08 10:15:59 EDT
fixed before we shipped 6.2.

Note You need to log in before you can comment on or make changes to this bug.