Bug 996367 - [RFE] Emphasize "Login" after registered
[RFE] Emphasize "Login" after registered
Status: CLOSED CURRENTRELEASE
Product: Zanata
Classification: Community
Component: Usability (Show other bugs)
3.0
Unspecified Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: Luke Brooker
Damian Jansen
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-13 00:34 EDT by Ding-Yi Chen
Modified: 2016-04-18 05:37 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-26 22:31:21 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ding-Yi Chen 2013-08-13 00:34:54 EDT
Description of problem:
The button "Sign Up" is always emphasized. Personally, I keep clicking 
on it even I already have registered accounts and login dozens of times.

Please make the "login" is emphasized after I registered.

Version-Release number of selected component (if applicable):
Zanata version 3.0.0-alpha-2-SNAPSHOT (20130812-0932)

How reproducible:
Always

Steps to Reproduce:
1. Complete registration.
2. Click the activation link

Actual results:
"Login" is less obvious then "Sign Up".

Expected results:
Login is should be easier to spot than Sign Up, since you can now "Login".

Additional info:
Comment 1 Luke Brooker 2013-08-14 20:14:40 EDT
This depends on our goals. Having the signup be slightly more noticeable than the login link is a commonly used pattern that people are used to.

What we should really be doing is automatically signing them in straight after they sign-up or if this is not possible at least taking them straight to the login page rather than making them click another link.
Comment 2 Ding-Yi Chen 2013-08-14 21:00:30 EDT
As far as I can see from the facebook, and Google, they put sign up and (In reply to Luke Brooker from comment #1)
> This depends on our goals. Having the signup be slightly more noticeable
> than the login link is a commonly used pattern that people are used to.

Google: Sign up is at the top right, Login is at the middle
Facebook: Sign up is at the middle, Login is at the top right.
Twitter: Sign up is at the right, Login is on upper of sign up.

I should say that both "Sign Up" and "Login" are all in the easy-to-spot places, but different places. Usually, one in the middle, the other one at the top right.


> What we should really be doing is automatically signing them in straight
> after they sign-up or if this is not possible at least taking them straight
> to the login page rather than making them click another link.

That only works for the first login.
They will still encounter the same problem on the 2nd, 3rd logins.

I keep telling myself "Don't click that 'Sign up' button, you already registered!"
Comment 3 Luke Brooker 2013-08-14 22:38:09 EDT
Good point on those. It's always a tricky thing on which one we should lean on more which is why I said it depends on our goals.

I have a bunch of changes I want to make to the login/account screen but for now I will make a few tweaks to the prototype.
Comment 5 Luke Brooker 2013-08-15 20:12:00 EDT
Changes have been merged into integration master. Purely to do with visual hierarchy of Sign Up/Log In buttons.

https://github.com/zanata/zanata-server/pull/132

Should probably have a another bug to do with the sign up process, although we can do that as part of one big change.
Comment 6 Damian Jansen 2013-08-15 21:58:34 EDT
The login box as the landing page is also a plus.
Verified at 78afafcedc492dbbbdead971f566cc30733971ee
Comment 7 Sean Flanigan 2013-11-26 22:31:21 EST
Closing VERIFIED bugs which predate Zanata 3.1.2.

Note You need to log in before you can comment on or make changes to this bug.