Bug 996390 - Coverity bug
Coverity bug
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: nfs (Show other bugs)
pre-release
Unspecified Unspecified
low Severity low
: ---
: ---
Assigned To: Meghana
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-13 02:11 EDT by rjoseph
Modified: 2015-08-31 22:54 EDT (History)
2 users (show)

See Also:
Fixed In Version: glusterfs-3.5.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-04-17 07:45:50 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description rjoseph 2013-08-13 02:11:25 EDT
Description of problem:
    Placeholder bug for fixing all coverity related issues.

http://cov01.lab.eng.brq.redhat.com/covscanhub/task/4845/log/glusterfs-3git-1.fc18/run1/glusterfs-3git-1.fc18.html

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 1 Anand Avati 2013-08-20 08:19:23 EDT
REVIEW: http://review.gluster.org/5660 (NFS : Coverity Fix.) posted (#1) for review on master by Meghana M (mmadhusu@redhat.com)
Comment 2 Anand Avati 2013-08-22 01:29:02 EDT
REVIEW: http://review.gluster.org/5660 (NFS : Coverity Fix.) posted (#2) for review on master by Meghana M (mmadhusu@redhat.com)
Comment 3 Anand Avati 2013-08-22 04:45:23 EDT
REVIEW: http://review.gluster.org/5660 (NFS : Coverity Fix.) posted (#3) for review on master by Meghana M (mmadhusu@redhat.com)
Comment 4 Anand Avati 2013-08-23 07:35:29 EDT
REVIEW: http://review.gluster.org/5660 (NFS : Coverity Fix.) posted (#4) for review on master by Meghana M (mmadhusu@redhat.com)
Comment 5 Anand Avati 2013-08-26 00:22:48 EDT
REVIEW: http://review.gluster.org/5660 (NFS : Coverity Fix.) posted (#5) for review on master by Meghana M (mmadhusu@redhat.com)
Comment 6 Anand Avati 2013-08-26 01:55:10 EDT
REVIEW: http://review.gluster.org/5660 (NFS : Coverity Fix.) posted (#6) for review on master by Meghana M (mmadhusu@redhat.com)
Comment 7 Anand Avati 2013-08-27 08:00:56 EDT
REVIEW: http://review.gluster.org/5660 (NFS : Coverity Fix.) posted (#7) for review on master by Meghana M (mmadhusu@redhat.com)
Comment 8 Anand Avati 2013-09-04 08:16:56 EDT
REVIEW: http://review.gluster.org/5660 (NFS : Coverity Fix.) posted (#8) for review on master by Meghana M (mmadhusu@redhat.com)
Comment 9 Anand Avati 2013-09-05 03:37:59 EDT
REVIEW: http://review.gluster.org/5660 (NFS : Coverity Fix.) posted (#9) for review on master by Meghana M (mmadhusu@redhat.com)
Comment 10 Anand Avati 2013-09-05 05:02:37 EDT
REVIEW: http://review.gluster.org/5660 (NFS : Coverity Fix.) posted (#10) for review on master by Meghana M (mmadhusu@redhat.com)
Comment 11 Anand Avati 2013-09-05 07:26:42 EDT
REVIEW: http://review.gluster.org/5660 (NFS : Coverity Fix.) posted (#11) for review on master by Meghana M (mmadhusu@redhat.com)
Comment 12 Anand Avati 2013-09-17 03:04:16 EDT
REVIEW: http://review.gluster.org/5660 (NFS : Coverity Fix.) posted (#12) for review on master by Meghana M (mmadhusu@redhat.com)
Comment 13 Anand Avati 2013-09-18 07:35:34 EDT
REVIEW: http://review.gluster.org/5660 (NFS : Coverity Fix.) posted (#13) for review on master by Meghana M (mmadhusu@redhat.com)
Comment 14 Anand Avati 2013-09-19 12:25:00 EDT
COMMIT: http://review.gluster.org/5660 committed in master by Anand Avati (avati@redhat.com) 
------
commit 7da8040d96ae16d6d2b6079ffd8cbcfe5d28aac4
Author: meghana <mmadhusu@redhat.com>
Date:   Tue Aug 20 15:13:42 2013 -0400

    NFS : Coverity Fix.
    
    NFS defects reported by  Coverity run are fixed.
    
    Change-Id: Ib66847e8e66fb4a06b312c80814f9eafb032eba2
    BUG: 996390
    Signed-off-by: meghana <mmadhusu@redhat.com>
    Reviewed-on: http://review.gluster.org/5660
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Varun Shastry <vshastry@redhat.com>
    Reviewed-by: Kaleb KEITHLEY <kkeithle@redhat.com>
Comment 15 Niels de Vos 2014-04-17 07:45:50 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.5.0, please reopen this bug report.

glusterfs-3.5.0 has been announced on the Gluster Developers mailinglist [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/6137
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.