Bug 996415 - Infinispan Query Guide - Chapter 8 Review
Infinispan Query Guide - Chapter 8 Review
Status: CLOSED CURRENTRELEASE
Product: JBoss Data Grid 6
Classification: JBoss
Component: Documentation (Show other bugs)
6.1.0
Unspecified Unspecified
unspecified Severity unspecified
: ER3
: 6.2.0
Assigned To: Mandar Joshi
gsheldon
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-13 02:55 EDT by gsheldon
Modified: 2015-08-31 22:58 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-15 19:03:31 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description gsheldon 2013-08-13 02:55:16 EDT
1) Rewrite and restructure Chapter 8 of the Infinispan Query Guide, looking out for:
 - passive voice.
 - casual language, ie. use of "you" and "we", and phrases such as "have a look", "let's try .." etc.

2) Configuration examples should be modified to remove annotations that are not included in JDG. The following are NOT valid in JDG:
 - @Entity
 - @Id
 - @GeneratedValue
 - @OneToOne
 - @OneToMany
 - @ManyToMany
 - @Lob

See the Chapter 7 topics for examples.

3) Check for non-Infinispan/JDG content.
 - Be wary of references to Hibernate queries and JPA. These are generally Hibernate Search specific, and should not be included in JDG.
 - Check with Sanne or Tristan to find out if examples or references to these things should be included in the docs.

4) Post your rewrites to http://middleware-docs.etherpad.corp.redhat.com/73 and email Sanne or Martin for feedback. 

5) Use this bug to track topics you have changed that have been SME checked.
Comment 4 Mandar Joshi 2013-09-16 08:22:23 EDT
Completed the changes to chapter 08.
Comment 5 Misha H. Ali 2013-09-19 20:15:42 EDT
Did you want this brewed? Can't see a revision history entry.
Comment 6 Mandar Joshi 2013-09-20 05:18:08 EDT
updated the revision history.
Comment 7 Misha H. Ali 2013-09-22 19:59:53 EDT
Brewed
Comment 9 Misha H. Ali 2013-09-30 20:37:47 EDT
Adding Gemma as QA for this one since she is the reporter. Gemma, please confirm if the changes you specified appear as required for this bug.
Comment 17 Mandar Joshi 2013-11-18 06:17:47 EST
Gemma, I have verified the changes on docstage. You can put this bug on Verified.
Thanks,
Mandar
Comment 18 Misha H. Ali 2013-11-18 06:21:21 EST
What you mean is that Gemma needs to verify the changes she asked you to do and confirm there aren't any others required for this chapter.
Comment 21 gsheldon 2013-11-19 19:53:11 EST
Looks great Mandar, thanks!

Setting to Verified.
Comment 22 Misha H. Ali 2014-01-15 19:03:31 EST
The fix for this bug is now generally released and available here:

https://access.redhat.com/site/documentation/en-US/Red_Hat_JBoss_Data_Grid/6.2/index.html

Note You need to log in before you can comment on or make changes to this bug.