Bug 996445 - The error message "GPT: Use GNU Parted to correct GPT errors." is logged in dmesg after installing RHEL6.4-64 with RAID1
The error message "GPT: Use GNU Parted to correct GPT errors." is logged in d...
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: report (Show other bugs)
6.4
x86_64 Linux
urgent Severity urgent
: rc
: ---
Assigned To: Gavin Romig-Koch
BaseOS QE - Apps
:
Depends On:
Blocks: 1002711 1069486
  Show dependency treegraph
 
Reported: 2013-08-13 03:52 EDT by matthew
Modified: 2016-02-02 08:33 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1069486 (view as bug list)
Environment:
Last Closed: 2015-09-18 09:53:49 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description matthew 2013-08-13 03:52:26 EDT
Description of problem:
Build RAID1 with 2 HDDs,then install RHEL6U4-64 in UEFI mode. After installing OS, it will show a error log in dmesg. 

dmesg :
[1.439366] GPT: Use GNU Parted to correct GPT errors.


Steps to Reproduce:
1. Build a RAID1 with 2HDDs.
2. Install RHEL6U4-64.
3. Check the dmesg log.

Expected results:
It has no any error in dmesg after installing RHEL6U4-64 with RAID1.
Comment 2 RHEL Product and Program Management 2013-10-13 19:16:08 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unable to address this
request at this time.

Red Hat invites you to ask your support representative to
propose this request, if appropriate, in the next release of
Red Hat Enterprise Linux.
Comment 4 yangfei 2014-01-25 22:45:31 EST
any update ???
Comment 5 yangfei 2014-02-18 23:13:49 EST
This issue just happened on RAID1. RAID1 build in hardware.
Comment 6 yangfei 2014-02-18 23:17:16 EST
(In reply to matthew from comment #0)
> Description of problem:
> Build RAID1 with 2 HDDs,then install RHEL6U4-64 in UEFI mode. After
> installing OS, it will show a error log in dmesg. 
> 
> dmesg :
> [1.439366] GPT: Use GNU Parted to correct GPT errors.
> 
> 
> Steps to Reproduce:
> 1. Build a RAID1 with 2HDDs.
> 2. Install RHEL6U4-64.
> 3. Check the dmesg log.
> 
> Expected results:
> It has no any error in dmesg after installing RHEL6U4-64 with RAID1.



messages:
kernel: GPT:Primary header thinks Alt. header is not at the end of the disk.
kernel: GPT:1855762431 != 1953525167
kernel: GPT:Alternate GPT header not at the end of the disk.
kernel: GPT:1855762431 != 1953525167
kernel: GPT: Use GNU Parted to correct GPT errors.
Comment 9 Chris Williams 2015-09-18 09:53:49 EDT
This Bugzilla has been reviewed by Red Hat and is not planned on being addressed in Red Hat Enterprise Linux 6 and therefore will be closed. If this bug is critical to production systems, please contact your Red Hat support representative and provide sufficient business justification.

Note You need to log in before you can comment on or make changes to this bug.