Bug 996493 - ABRT considers as duplicates LibreOffice backtraces that are different
ABRT considers as duplicates LibreOffice backtraces that are different
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: satyr (Show other bugs)
19
All Linux
high Severity medium
: ---
: ---
Assigned To: Martin Milata
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-13 05:44 EDT by Milan Bouchet-Valat
Modified: 2013-11-28 09:30 EST (History)
8 users (show)

See Also:
Fixed In Version: satyr-0.11-1.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-28 09:30:11 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Milan Bouchet-Valat 2013-08-13 05:44:50 EDT
Recently a crash I experienced with LibreOffice in Fedora 19 was considered by ABRT as a duplicate of another one, but the two backtraces where actually very different. ABRT got confused by abort handlers that were the same at the top of the trace:

hread 1 (Thread 0x7f0502cbd840 (LWP 2247)):
#0  0x00000032e2c35a19 in __GI_raise (sig=sig@entry=6) at ../nptl/sysdeps/unix/sysv/linux/raise.c:56
        resultvar = 0
        pid = 2247
        selftid = 2247
#1  0x00000032e2c37128 in __GI_abort () at abort.c:90
        save_stage = 2
        act = {__sigaction_handler = {sa_handler = 0x4d908e8, sa_sigaction = 0x4d908e8}, sa_mask = {__val = {0, 33469760, 218544269478, 214748364805, 0, 45, 218552626432, 83207296, 33469760, 139659183564992, 218544296661, 45, 218553543149, 218556512800, 45, 0}}, sa_flags = -486819296, sa_restorer = 0x32e6cbec10}
        sigs = {__val = {32, 0 <repeats 15 times>}}
#2  0x00000032e6c60545 in __gnu_cxx::__verbose_terminate_handler () at ../../../../libstdc++-v3/libsupc++/vterminate.cc:95
        terminating = true
        t = <optimized out>
#3  0x00000032e6c5e6a6 in __cxxabiv1::__terminate (handler=<optimized out>) at ../../../../libstdc++-v3/libsupc++/eh_terminate.cc:38
No locals.
#4  0x00000032e6c5e6d3 in std::terminate () at ../../../../libstdc++-v3/libsupc++/eh_terminate.cc:48
No locals.


This may result in a very poor reporting of LibreOffice bugs if all aborts are considered the same, and the backtraces are not uploaded automatically.


The two bugs are
https://bugzilla.redhat.com/show_bug.cgi?id=995696
and
https://bugs.freedesktop.org/show_bug.cgi?id=68046
Comment 1 Martin Milata 2013-10-08 07:03:03 EDT
Thanks for the report. Patch has been posted for reivew: https://github.com/abrt/satyr/pull/119
Comment 2 Martin Milata 2013-11-28 09:30:11 EST
Should be fixed in satyr-0.11-1.fc19.

Note You need to log in before you can comment on or make changes to this bug.