Bug 996587 - skip options should not be available for repositories that don't have a feed
skip options should not be available for repositories that don't have a feed
Status: CLOSED NOTABUG
Product: Pulp
Classification: Community
Component: user-experience (Show other bugs)
Master
Unspecified Unspecified
low Severity unspecified
: ---
: ---
Assigned To: pulp-bugs
Preethi Thomas
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-13 09:34 EDT by Preethi Thomas
Modified: 2014-11-25 10:56 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-11-25 10:56:05 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Preethi Thomas 2013-08-13 09:34:45 EDT
Description of problem:
--skip options does not really do anything reposotories without feed. So best would be to make it not available for them. It should work similar to the other options that are not available for non feeded repos


For example

[root@cloud-qe-18 ~]#  pulp-admin rpm repo create  --repo-id local --feed-ca-cert CDN/cdn.redhat.com-chain.crt --feed-cert CDN/1359391926_4512.crt  --feed-key CDN/1359391926_4512.keyThe server indicated one or more values were incorrect. The server provided the
following error message:

   Configuration errors:
The configuration parameter <feed> is required when any
of the following other parameters are defined: max_speed, max_downloads,
proxy_password, proxy_port, proxy_host, proxy_username, retain_old_count,
ssl_ca_cert, ssl_client_cert, ssl_client_key, validate

More information can be found in the client log file ~/.pulp/admin.log.

[root@cloud-qe-18 ~]# 



Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 1 Chris Duryee 2014-11-11 21:49:25 EST
It looks like feed option checking has been removed in #1019455. Is it OK to close this bz?
Comment 2 Preethi Thomas 2014-11-25 10:56:05 EST
sure.  I think closing the bz is appropriate in this case

Note You need to log in before you can comment on or make changes to this bug.