Bug 996595 - Device /dev/sda2 not found (or ignored by filtering).
Device /dev/sda2 not found (or ignored by filtering).
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: anaconda (Show other bugs)
6.5
Unspecified Unspecified
high Severity high
: alpha
: ---
Assigned To: Anaconda Maintenance Team
Release Test Team
: Regression
Depends On:
Blocks: 885755 972747
  Show dependency treegraph
 
Reported: 2013-08-13 09:45 EDT by Marian Ganisin
Modified: 2013-11-21 04:37 EST (History)
3 users (show)

See Also:
Fixed In Version: anaconda-13.21.203-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-21 04:37:00 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Marian Ganisin 2013-08-13 09:45:29 EDT
Description of problem:

During interactive mode anaconda added all partitions to ignore list for lvm command.

Version-Release number of selected component (if applicable):
anaconda version 13.21.202 on all architectures

How reproducible:
This happened during testing of interactive installation, there was already some layout

Actual results:
pvcreate cannot create pv as the desired partition is on filter list

Expected results:
All disks and disk partition added

Additional info:
Some changes seem to be introduced by patch 62556809, maybe this could be the cause. Btw indentation in this patch seems to be incorrect after the patch, log.debug msg seems to be printed even if no addition to filter happens.

The issue didn't occur in previous builds.
Comment 5 Samantha N. Bueno 2013-08-14 09:52:03 EDT
I'm reverting the changes in 885755 which caused this bug. Patch posted.
Comment 6 Samantha N. Bueno 2013-08-14 10:14:12 EDT
Patch pushed to rhel6-branch, commit 67f5c415027a4486733194be83a560a1d0b4181a.
Comment 9 errata-xmlrpc 2013-11-21 04:37:00 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1588.html

Note You need to log in before you can comment on or make changes to this bug.