Bug 996632 - No man page for /usr/sbin/foreman-proxy-configure in katello-configure
No man page for /usr/sbin/foreman-proxy-configure in katello-configure
Status: CLOSED WONTFIX
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Installer (Show other bugs)
6.0.0
Unspecified Unspecified
unspecified Severity medium (vote)
: Unspecified
: --
Assigned To: Ivan Necas
Katello QA List
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-13 10:45 EDT by Bryan Kearney
Modified: 2014-06-19 15:07 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-03 14:57:10 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bryan Kearney 2013-08-13 10:45:56 EDT
No man page for /usr/sbin/foreman-proxy-configure in the katello installer
Comment 1 RHEL Product and Program Management 2013-09-17 00:18:55 EDT
Since this issue was entered in Red Hat Bugzilla, the release flag has been
set to ? to ensure that it is properly evaluated for this release.
Comment 5 Lukas Zapletal 2013-10-21 11:02:40 EDT
Step one: https://github.com/theforeman/kafo/pull/33

Step two: implement a template for a desired package (foreman-installer):

$ cat man/foreman-installer.8.asciidoc | paste
http://sprunge.us/AbfG

Step three: edit SPEC file to generate it:

kafo-export-params -c /usr/share/foreman-installer/config/foreman-installer.yaml -f asciidoc > snippet.asciidoc
sed /@@XXX@@@/snippet/
a2x -d manpage -f manpage foreman-installer.8.asciidoc

The step three is pseudocode, I am waiting until kafo is released with the patch :-) I will proceed with foreman-installer, please to the same for proxy-configure...
Comment 8 Corey Welton 2014-06-03 14:57:10 EDT
No longer supported - closing this as wontfix

Note You need to log in before you can comment on or make changes to this bug.