Bug 996661 - Printers missing from printer discovery list
Printers missing from printer discovery list
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: system-config-printer (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Tim Waugh
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-13 11:44 EDT by David Woodhouse
Modified: 2013-08-19 16:18 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-14 16:56:28 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Bugzilla 705851 None None None Never

  None (edit)
Description David Woodhouse 2013-08-13 11:44:39 EDT
If more than one printer of a given model is discovery by CUPS, control-center chooses to display only *one* of them.

As described in the upstream bug, you don't have to buy a matching pair of printers to test this. You can do it with a simple shell script like this in
/usr/lib/cups/backends:

#!/bin/sh

cat <<EOF
socket socket://127.0.0.1:9100 "foo1" "bar1" "MDL:HP LaserJet M5035 MFP" "left"
socket socket://127.0.0.2:9100 "foo2" "bar2" "MDL:HP LaserJet M5035 MFP" "right"
EOF
Comment 1 David Woodhouse 2013-08-14 11:44:23 EDT
The code in pp-new-printer-dialog.c appears to be almost completely uncommented but it looks like the problem might actually be with the GroupPhysicalDevices method in system-config-printer.

The two devices of the same type are grouped together in the response:

      array [
         string "http"
         string "https"
         string "ipps"
         string "smb"
      ]
      array [
         string "socket://127.0.0.1"
         string "socket://127.0.0.2"
      ]

And this appears to make the dialog ignore all but the first.
Comment 2 Tim Waugh 2013-08-14 12:11:10 EDT
"socket" is not a valid device class (first field).  I think you want 'network' there?
Comment 3 David Woodhouse 2013-08-14 16:56:28 EDT
Doh! That makes it work much better — thanks!

Now I have the opposite problem. If I add one of these "discovered" printers, and then go to add another, the original one that I already added is still there. The control-center code was trying to filter those out, wasn't it?
Comment 4 Marek Kašík 2013-08-19 07:02:55 EDT
(In reply to David Woodhouse from comment #3)
> Now I have the opposite problem. If I add one of these "discovered"
> printers, and then go to add another, the original one that I already added
> is still there. The control-center code was trying to filter those out,
> wasn't it?

Hi David,

control-center doesn't try to filter already added printers out. It keeps them there because user might want to have the same printer with different settings.

Marek
Comment 5 David Woodhouse 2013-08-19 16:18:36 EDT
Makes sense; thanks for the update.

I have all this working fairly nicely now. Apart from the PIN-based secure printing, which works kind of sporadically. qv.

Note You need to log in before you can comment on or make changes to this bug.