Bug 996677 - Add ruby193-ruby-wrapper & Update ruby193-ruby
Add ruby193-ruby-wrapper & Update ruby193-ruby
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: ruby193-ruby-wrapper (Show other bugs)
3.0
Unspecified Unspecified
urgent Severity high
: z2
: 3.0
Assigned To: Lon Hohberger
Omri Hochman
: CodeChange, ZStream
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-13 13:00 EDT by Lon Hohberger
Modified: 2014-01-09 14:37 EST (History)
3 users (show)

See Also:
Fixed In Version: ruby193-ruby-wrapper-0.0.1-2.el6ost
Doc Type: Bug Fix
Doc Text:
The previous version of ruby 1.9.3 was outdated. However, the way it was packaged, it included wrapper scripts which were used by the Foreman. This meant that many bugfixes present in later patch levels of ruby 1.9.3 were not available. This was fixed by separating the wrapper scripts into their own package. This allows later versions of ruby 1.9.3 to be provided (in this case, patch level 448), which contain numerous fixes. Now, when using the Foreman, you will see two packages (ruby193-ruby and ruby193-ruby-wrapper) instead of one.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-03 15:58:47 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Lon Hohberger 2013-08-13 13:00:18 EDT
Description of problem:

The reliance on older ruby builds is based on a set of scripts disappearing from later builds.  This package is simply those scripts in their own RPM.  This allows us to use later ruby193-ruby builds.
Comment 6 Bruce Reeler 2013-08-25 22:23:35 EDT
NEEDINFO for Lon
I am writing the Doc Text for bug advisories, but this one has me stumped and I can't even provide draft text! Could you please write a brief summary in the Doc Text field about what the impact of this bugfix is for admins or users. Thanks.
Comment 7 Lon Hohberger 2013-08-26 12:35:37 EDT
The only user-visible change here is packaging.

When using the Foreman, you should see two packages instead of one (ruby193-ruby and ruby193-ruby-wrapper).  The Foreman has been tested by development to continue operating with this new package split.
Comment 8 Omri Hochman 2013-08-27 09:53:21 EDT
Verified : (puddle 2013-08-23.1) : 

Two rpm packages exist: 
-------------------------
ruby193-ruby-1.9.3.448-38.el6.x86_64
ruby193-ruby-wrapper-0.0.1-2.el6ost.noarch

Sanity test passed fine - and included:  
----------------------------------------
-Installation of foreman-server using foreman_server.sh. 
-Register 2 clients to foreman-server using foreman_client.sh 
-Deployed on 1 client as openstack 'controller'. 
-Deployed on 1 client as openstack 'compute'.
-Verify that the compute-node is register to the controller machine.
Comment 9 Omri Hochman 2013-08-27 09:57:14 EDT
Note: In order to workaround BZ#993642 I had to downgrade to older packstack-modules-puppet:  (packstack-modules-puppet-2013.1.1-0.23.dev642.el6ost.noarch)

The fix for that should be released with: ruby193-openstack-foreman-installer-0.0.18-3.el6ost (which is not yet available)
Comment 10 errata-xmlrpc 2013-09-03 15:58:47 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1186.html

Note You need to log in before you can comment on or make changes to this bug.