Bug 996682 - Build libitm with HTM
Build libitm with HTM
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: gcc-libraries (Show other bugs)
6.5
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Marek Polacek
Dagmar Prokopová
:
Depends On:
Blocks: 996683
  Show dependency treegraph
 
Reported: 2013-08-13 13:10 EDT by Marek Polacek
Modified: 2014-07-01 18:54 EDT (History)
5 users (show)

See Also:
Fixed In Version: gcc-libraries-4.8.1-4.2.1.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 996683 (view as bug list)
Environment:
Last Closed: 2013-11-21 06:06:05 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
htm-in-asm (1.38 KB, patch)
2013-08-13 13:13 EDT, Marek Polacek
no flags Details | Diff

  None (edit)
Description Marek Polacek 2013-08-13 13:10:40 EDT
Currently, we build libitm.so with the system RHEL binutils; these don't support HTM.  Yet we want the HTM bits in the libitm.

objdump -dr on libitm.so.1 should show xbegin, xend etc insns.
Comment 1 Marek Polacek 2013-08-13 13:13:35 EDT
Created attachment 786217 [details]
htm-in-asm

A patch to do that.
Comment 4 Marek Polacek 2013-08-14 07:35:18 EDT
QA: Note that for testing you'll have to use objdump from at least F17; F16 is too old.
Comment 5 Marek Polacek 2013-08-14 07:45:02 EDT
Fixed.
Comment 7 Dagmar Prokopová 2013-08-14 14:12:48 EDT
Verified for gcc-libraries-4.8.1-4.2.1.el6.
Comment 8 errata-xmlrpc 2013-11-21 06:06:05 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1607.html

Note You need to log in before you can comment on or make changes to this bug.