Bug 996683 - Build libitm with HTM
Build libitm with HTM
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: gcc-libraries (Show other bugs)
5.10
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Marek Polacek
qe-baseos-tools
:
Depends On: 996682
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-13 13:14 EDT by Marek Polacek
Modified: 2014-02-12 09:49 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 996682
Environment:
Last Closed: 2014-02-12 09:49:28 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Marek Polacek 2013-08-13 13:14:53 EDT
+++ This bug was initially created as a clone of Bug #996682 +++

Currently, we build libitm.so with the system RHEL binutils; these don't support HTM.  Yet we want the HTM bits in the libitm.

objdump -dr on libitm.so.1 should show xbegin, xend etc insns.

--- Additional comment from Marek Polacek on 2013-08-13 13:13:35 EDT ---

A patch to do that.
Comment 1 Marek Polacek 2013-08-14 07:30:05 EDT
Nothing to do yet, will do a build when 5.11 branch is open.
Comment 4 Matt Newsome 2014-02-12 09:49:28 EST
This bugzilla has been reviewed by Red Hat. It is not planned to address this in Red Hat Enterprise Linux 5, and therefore will be closed. If this bug is critical to production systems, please contact your Red Hat support representative and provide sufficient business justification. The issue is already fixed in RHEL-6/7.

Note You need to log in before you can comment on or make changes to this bug.