Bug 996693 - [abrt] wicd-gtk-1.7.2.4-6.fc19: connection.py:651:call_blocking:DBusException: org.freedesktop.DBus.Python.TypeError: Traceback (most recent call last):
[abrt] wicd-gtk-1.7.2.4-6.fc19: connection.py:651:call_blocking:DBusException...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: wicd (Show other bugs)
19
i686 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: David Cantrell
Fedora Extras Quality Assurance
abrt_hash:5cb3777941f35affedc7caf9432...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-13 13:58 EDT by alain.thiaville
Modified: 2014-09-26 05:07 EDT (History)
5 users (show)

See Also:
Fixed In Version: wicd-1.7.2.4-8.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-09-26 05:06:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (2.60 KB, text/plain)
2013-08-13 13:58 EDT, alain.thiaville
no flags Details
File: environ (1.76 KB, text/plain)
2013-08-13 13:58 EDT, alain.thiaville
no flags Details

  None (edit)
Description alain.thiaville 2013-08-13 13:58:09 EDT
Version-Release number of selected component:
wicd-gtk-1.7.2.4-6.fc19

Additional info:
reporter:       libreport-2.1.6
cmdline:        /usr/bin/python -O /usr/share/wicd/gtk/wicd-client.py --tray
dso_list:       dbus-python-1.1.1-5.fc19.i686
executable:     /usr/share/wicd/gtk/wicd-client.py
kernel:         3.10.4-300.fc19.i686.PAE
runlevel:       N 5
type:           Python
uid:            0

Truncated backtrace:
connection.py:651:call_blocking:DBusException: org.freedesktop.DBus.Python.TypeError: Traceback (most recent call last):
  File "/usr/lib/python2.7/site-packages/dbus/service.py", line 707, in _message_cb
    retval = candidate_method(self, *args, **keywords)
  File "/usr/share/wicd/daemon/wicd-daemon.py", line 1066, in SetWirelessProperty
    prop = misc.sanitize_config(prop)
  File "/usr/lib/python2.7/site-packages/wicd/misc.py", line 433, in sanitize_config
    return s.translate(None, table)
TypeError: translate() takes exactly one argument (2 given)


Traceback (most recent call last):
  File "/usr/share/wicd/gtk/gui.py", line 676, in edit_advanced
    if self.run_settings_dialog(dialog, ttype, networkid, networkentry):
  File "/usr/share/wicd/gtk/gui.py", line 689, in run_settings_dialog
    if self.save_settings(nettype, networkid, networkentry):
  File "/usr/share/wicd/gtk/gui.py", line 654, in save_settings
    if not networkentry.save_wireless_settings(networkid):
  File "/usr/share/wicd/gtk/netentry.py", line 940, in save_wireless_settings
    return self.advanced_dialog.save_settings(networkid)
  File "/usr/share/wicd/gtk/netentry.py", line 591, in save_settings
    encrypt_methods[self.combo_encryption.get_active()]['type'])
  File "/usr/share/wicd/gtk/netentry.py", line 532, in set_net_prop
    wireless.SetWirelessProperty(self.networkID, option, value)
  File "/usr/lib/python2.7/site-packages/dbus/proxies.py", line 145, in __call__
    **keywords)
  File "/usr/lib/python2.7/site-packages/dbus/connection.py", line 651, in call_blocking
    message, timeout)
DBusException: org.freedesktop.DBus.Python.TypeError: Traceback (most recent call last):
  File "/usr/lib/python2.7/site-packages/dbus/service.py", line 707, in _message_cb
    retval = candidate_method(self, *args, **keywords)
  File "/usr/share/wicd/daemon/wicd-daemon.py", line 1066, in SetWirelessProperty
    prop = misc.sanitize_config(prop)
  File "/usr/lib/python2.7/site-packages/wicd/misc.py", line 433, in sanitize_config
    return s.translate(None, table)
TypeError: translate() takes exactly one argument (2 given)


Local variables in innermost frame:
byte_arrays: False
self: <dbus._dbus.SystemBus (system) at 0xa2c505c>
args: (0, 'enctype', 'wpa')
object_path: '/org/wicd/daemon/wireless'
signature: u'vvv'
bus_name: dbus.UTF8String(':1.2')
get_args_opts: {'byte_arrays': False, 'utf8_strings': False}
timeout: -1.0
kwargs: {}
dbus_interface: 'org.wicd.daemon.wireless'
message: <dbus.lowlevel.MethodCallMessage path: /org/wicd/daemon/wireless, iface: org.wicd.daemon.wireless, member: SetWirelessProperty dest: :1.2>
method: 'SetWirelessProperty'

Potential duplicate: bug 903422
Comment 1 alain.thiaville 2013-08-13 13:58:20 EDT
Created attachment 786229 [details]
File: backtrace
Comment 2 alain.thiaville 2013-08-13 13:58:27 EDT
Created attachment 786230 [details]
File: environ
Comment 3 Aiden Neal 2013-08-13 14:38:25 EDT
Description of problem:
I opened wicd's graphical frontend, and there were seemingly no problems.

Version-Release number of selected component:
wicd-gtk-1.7.2.4-6.fc19

Additional info:
reporter:       libreport-2.1.6
cmdline:        /usr/bin/python -O /usr/share/wicd/gtk/wicd-client.py --no-tray
dso_list:       dbus-python-1.1.1-5.fc19.x86_64
executable:     /usr/share/wicd/gtk/wicd-client.py
kernel:         3.10.5-201.fc19.x86_64
runlevel:       N 5
type:           Python
uid:            1000

Truncated backtrace:
connection.py:651:call_blocking:DBusException: org.freedesktop.DBus.Python.TypeError: Traceback (most recent call last):
  File "/usr/lib/python2.7/site-packages/dbus/service.py", line 707, in _message_cb
    retval = candidate_method(self, *args, **keywords)
  File "/usr/share/wicd/daemon/wicd-daemon.py", line 1410, in SetWiredProperty
    prop = misc.sanitize_config(prop)
  File "/usr/lib/python2.7/site-packages/wicd/misc.py", line 433, in sanitize_config
    return s.translate(None, table)
TypeError: translate() takes exactly one argument (2 given)


Traceback (most recent call last):
  File "/usr/share/wicd/gtk/netentry.py", line 846, in toggle_default_profile
    self.chkbox_default_profile.get_active())
  File "/usr/lib/python2.7/site-packages/dbus/proxies.py", line 145, in __call__
    **keywords)
  File "/usr/lib/python2.7/site-packages/dbus/connection.py", line 651, in call_blocking
    message, timeout)
DBusException: org.freedesktop.DBus.Python.TypeError: Traceback (most recent call last):
  File "/usr/lib/python2.7/site-packages/dbus/service.py", line 707, in _message_cb
    retval = candidate_method(self, *args, **keywords)
  File "/usr/share/wicd/daemon/wicd-daemon.py", line 1410, in SetWiredProperty
    prop = misc.sanitize_config(prop)
  File "/usr/lib/python2.7/site-packages/wicd/misc.py", line 433, in sanitize_config
    return s.translate(None, table)
TypeError: translate() takes exactly one argument (2 given)


Local variables in innermost frame:
byte_arrays: False
self: <dbus._dbus.SystemBus (system) at 0x2a39bf0>
args: ('default', True)
object_path: '/org/wicd/daemon/wired'
signature: u'vv'
bus_name: dbus.UTF8String(':1.5')
get_args_opts: {'byte_arrays': False, 'utf8_strings': False}
timeout: -1.0
kwargs: {}
dbus_interface: 'org.wicd.daemon.wired'
message: <dbus.lowlevel.MethodCallMessage path: /org/wicd/daemon/wired, iface: org.wicd.daemon.wired, member: SetWiredProperty dest: :1.5>
method: 'SetWiredProperty'
Comment 4 Aiden Neal 2013-08-13 18:46:45 EDT
Actually, I've just discovered that there *were* problems caused by the bug.  The problem is triggered whenever the checkbox is ticked to select a connection as the default one, and the selection does not become marked as default.  I noticed this when wicd wouldn't automatically pick the default connection on startup like I told it to, since there was no default at all.
Comment 5 Robert Xu 2013-08-30 16:04:49 EDT
Bugfix from arch: https://bbs.archlinux.org/viewtopic.php?pid=1097401

Just tried this fix on Fedora 19 and it works for me.
Comment 6 John Anderson 2013-12-09 01:56:23 EST
+1 for getting this applied.  The reason this is happening is because its getting a unicode string which has a different translate function than a standard string.

you could also s.encode(´utf-8´) to make this work.
Comment 7 Fedora Update System 2014-07-02 11:35:42 EDT
wicd-1.7.2.4-8.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/wicd-1.7.2.4-8.fc19
Comment 8 Fedora Update System 2014-07-02 11:51:44 EDT
wicd-1.7.2.4-11.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/wicd-1.7.2.4-11.fc20
Comment 9 Fedora Update System 2014-07-03 00:04:43 EDT
Package wicd-1.7.2.4-11.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing wicd-1.7.2.4-11.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2014-8008/wicd-1.7.2.4-11.fc20
then log in and leave karma (feedback).
Comment 10 Fedora Update System 2014-09-26 05:06:10 EDT
wicd-1.7.2.4-11.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 11 Fedora Update System 2014-09-26 05:07:00 EDT
wicd-1.7.2.4-8.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.