Bug 996694 - Update inifile module to support empty values
Update inifile module to support empty values
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-packstack (Show other bugs)
3.0
Unspecified Unspecified
unspecified Severity high
: z2
: 3.0
Assigned To: Martin Magr
Nir Magnezi
: Triaged, ZStream
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-13 13:59 EDT by Terry Wilson
Modified: 2014-01-09 14:37 EST (History)
7 users (show)

See Also:
Fixed In Version: openstack-packstack-2013.1.1-0.27.dev660.el6ost
Doc Type: Bug Fix
Doc Text:
Previously, the inifile module did not manage empty values well. Empty values need to be able to be set for Neutron. This has been fixed and the inifile module now manages empty values correctly.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-03 15:58:51 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Terry Wilson 2013-08-13 13:59:08 EDT
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 1 Terry Wilson 2013-08-13 14:02:09 EDT
The inifile module doesn't handle setting empty values well. We need to be able to set empty values in neutron. This has been fixed in the upstream inifile module.
Comment 3 Nir Magnezi 2013-08-18 08:05:58 EDT
(In reply to Terry Wilson from comment #1)
> The inifile module doesn't handle setting empty values well. We need to be
> able to set empty values in neutron. This has been fixed in the upstream
> inifile module.

By inifile you mean packstack answer file?
Please add some information:
1. Are there specific values to test?
2. How to reproduce the issue? 
3. How to verify the fix?
Comment 4 Martin Magr 2013-08-19 07:07:49 EDT
The update part was Puppet module puppetlabs-inifile [1] located at packstack/puppet/modules/inifile. 

We needed that to support adding empty value of "DEFAULT/external_network_bridge" to /etc/neutron/l3_agent.ini when using "provider" value in packstack's parameter CONFIG_NEUTRON_L3_EXT_BRIDGE. AFAIK before this patch each packstack run added one line with that configuration to the config file.

[1] https://github.com/puppetlabs/puppetlabs-inifile
Comment 5 Nir Magnezi 2013-08-20 08:10:51 EDT
Verified NVR: openstack-packstack-2013.1.1-0.27.dev660.el6ost.noarch
1. Installed openstack via packstack with packstack answer file CONFIG_QUANTUM_L3_EXT_BRIDGE=provider

2. # grep external_network_bridge /etc/quantum/l3_agent.ini  | grep -v "#"
external_network_bridge = 

Please note that packstack-2013.1.1-0.27.dev660 still uses the word quantum and not neutron as specified comment #4
Comment 6 Bruce Reeler 2013-08-24 00:00:41 EDT
Needinfo for Martin Magr
I am writing the Doc Text for bug advisories. As the Doc Text field was blank, I have written the current Doc Text from scratch. Could you please comment or edit it and correct as necessary. Thanks.
Comment 7 Martin Magr 2013-08-26 06:32:58 EDT
Doc text is modidied a littlebit. Now it's OK.
Comment 8 errata-xmlrpc 2013-09-03 15:58:51 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1186.html

Note You need to log in before you can comment on or make changes to this bug.