This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 996764 - aether rawhide update seems to have internal resolution troubles
aether rawhide update seems to have internal resolution troubles
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: aether (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Mikolaj Izdebski
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-13 17:46 EDT by Michal Jaegermann
Modified: 2013-08-14 02:15 EDT (History)
3 users (show)

See Also:
Fixed In Version: 0.9.0-0.4.M3
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-14 02:15:13 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michal Jaegermann 2013-08-13 17:46:54 EDT
Description of problem:

On an attempt to apply the current updates the following happens:

---> Package aether-api.noarch 1:0.9.0-0.2.M2.fc20 will be updated
--> Processing Dependency: mvn(org.eclipse.aether:aether-api) = 0.9.0.M2 for package: 1:aether-connector-file-0.9.0-0.2.M2.fc20.noarch
---> Package aether-api.noarch 1:0.9.0-0.3.M3.fc20 will be an update
.....
--> Running transaction check
---> Package aether-api.noarch 1:0.9.0-0.2.M2.fc20 will be updated
--> Processing Dependency: mvn(org.eclipse.aether:aether-api) = 0.9.0.M2 for package: 1:aether-connector-file-0.9.0-0.2.M2.fc20.noarch
---> Package aether-connector-basic.noarch 1:0.9.0-0.3.M3.fc20 will be installed
---> Package aether-spi.noarch 1:0.9.0-0.2.M2.fc20 will be updated
--> Processing Dependency: mvn(org.eclipse.aether:aether-spi) = 0.9.0.M2 for package: 1:aether-connector-file-0.9.0-0.2.M2.fc20.noarch
---> Package aether-util.noarch 1:0.9.0-0.2.M2.fc20 will be updated
--> Processing Dependency: mvn(org.eclipse.aether:aether-util) = 0.9.0.M2 for package: 1:aether-connector-file-0.9.0-0.2.M2.fc20.noarch
--> Finished Dependency Resolution
Error: Package: 1:aether-connector-file-0.9.0-0.2.M2.fc20.noarch (@rawhide)
           Requires: mvn(org.eclipse.aether:aether-api) = 0.9.0.M2
           Removing: 1:aether-api-0.9.0-0.2.M2.fc20.noarch (@rawhide)
               mvn(org.eclipse.aether:aether-api) = 0.9.0.M2
           Updated By: 1:aether-api-0.9.0-0.3.M3.fc20.noarch (rawhide)
               mvn(org.eclipse.aether:aether-api) = 0.9.0.M3
......

As mvn(org.eclipse.aether:aether-api) is provided by aether-api.noarch that apparently means that aether-connector-file vanished.  If that is deliberate then it looks like that some "obsoletes" are missing.

Version-Release number of selected component (if applicable):
aether-0.9.0-0.3.M3.fc20
Comment 1 Mikolaj Izdebski 2013-08-14 01:27:35 EDT
In latest version of aether 3 subpackages were removed:
  * aether-connector-asynchttpclient
  * aether-connector-wagon
  * aether-connector-file

The first two are obsoleted, but the last one is not.
I'll add the missing Obsoletes.
Comment 2 Mikolaj Izdebski 2013-08-14 01:29:27 EDT
Fixed in aether-0.9.0-0.4.M3
Comment 3 Mikolaj Izdebski 2013-08-14 02:15:13 EDT
I believe that this bug is fixed in aether-0.9.0-0.4.M3,
which is available in Fedora Rawhide, so I am closing this bug now.

The build containing the fix can be found at Koji:
http://koji.fedoraproject.org/koji/buildinfo?buildID=456549

Note You need to log in before you can comment on or make changes to this bug.