Bug 996807 - Connection refused when trying to connect to HP Deskjet 3512
Connection refused when trying to connect to HP Deskjet 3512
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: hplip (Show other bugs)
18
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Tim Waugh
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-13 22:29 EDT by Peter H. Jones
Modified: 2013-08-14 09:23 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-14 09:23:25 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
printer installer troubleshooter output (2.26 KB, text/plain)
2013-08-13 22:29 EDT, Peter H. Jones
no flags Details

  None (edit)
Description Peter H. Jones 2013-08-13 22:29:32 EDT
Created attachment 786384 [details]
printer installer troubleshooter output

Description of problem:
Can't connect to HP Deskjet 3512 over wifi in FC18. Works fine in FC19. Connection to printer via USB works fine.

Version-Release number of selected component (if applicable):
hplip-common-3.13.7-1.fc18.x86_64
hplip-3.13.7-1.fc18.x86_64
hplip-libs-3.13.7-1.fc18.x86_64


How reproducible:
Always

Steps to Reproduce:
1. Configure an HP Deskjet 3512 to connect to a wifi hub. A USB connection is reaquired to configure the printer's wifi connection information, if connecting with a WEP/WPA password.
2. On printer display, make sure blue "connected" key/light is on. Press it to get the IP address.
3. In Applications-Menu/Administration/Printer-Settings, try to add the printer. (Be prepared to enter the root password twice).

Actual results:
The installation fails after a message about searching "whatrequires". I wish I had a way of finding out what that means, so I could supply what is lacking.

I used the Help u in Printer-Settings to trouleshoot. I got a file indicating "Connection Refused", attached.
 

Expected results:

No-hassle connect.

Additional info:

Normally, a direct USB connection would be required to configure the printer to connect to a WPA/WEP network. I didn't do that because I had already succeeded in doing that in FC19. Also in FC19, the installation proceeded flawlessly.
After my wireless connection attempt failed in FC18, I made successful USB installation in FC18.
Comment 1 Peter H. Jones 2013-08-13 23:20:55 EDT
Installed
hplip-gui-3.13.7-1.fc18.x86_64 (and its dependency python-reportlab-2.5-5.fc18.x86_64)

From Applications-Menu/Administration/HP-Device-Manager, was able to get status reports from the printer. When I tried to check the WEP password, I saw the field was blank, but the blue light on the printer showed it was connected. I suppose the password is hidden as a security measure.

From the File menu, I tried Diagnose HPLIP driver, and found a number of missing packages. Perhaps they should be added as dependencies in the RPM repositories. They are listed in red as follows:

SELinux         disabled        Optional   -   -   OK       -
Missing Required Dependencies
-----------------------------
error: 'cups' package is missing or 'cups' service is not running.
error: 'libjpeg-devel' package is missing/incompatible 
error: 'cups-devel' package is missing or 'cups' service is not running.
error: 'sane-backends-devel' package is missing/incompatible 
error: 'libusb1-devel' package is missing/incompatible 
error: 'cups-devel' package is missing or 'cups' service is not running.
error: 'net-snmp-devel' package is missing/incompatible 
error: 'audit' package is missing/incompatible 
error: 'gcc-c++' package is missing/incompatible 
Missing Optional Dependencies
-----------------------------
error: 'xsane' package is missing/incompatible 
 
I'm surprised at the number of "devel" packages reported. Perhaps this is because I' using a version from the "testing" repository, because the available one didn't recognize the printer in FC18, while the next one, available in FC19 and in testing in FC18, worked fine.
Comment 2 Peter H. Jones 2013-08-14 09:23:25 EDT
When I went back to the FC19 system, I found the printer no longer worked in network mode because its IP address had changed. I reconfigured the router to always assign the same IP address, and removed/reinstalled the network printer.

Returning to the FC18 system, I waited a bit longer after seeing the intimidating "Driver was not found on any software source" screen. The installation proceeded successfully (i.e. I can get status reports from the printer in network mode).

Note You need to log in before you can comment on or make changes to this bug.