Bug 996811 - [abrt] hplip-3.13.7-1.fc18: wifi.py:628:getLocation:UnicodeDecodeError: 'ascii' codec can't decode byte 0xac in position 0: ordinal not in range(128)
[abrt] hplip-3.13.7-1.fc18: wifi.py:628:getLocation:UnicodeDecodeError: 'asci...
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: hplip (Show other bugs)
18
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Tim Waugh
Fedora Extras Quality Assurance
abrt_hash:e68758a8ce99550af05a05ca16b...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-13 22:40 EDT by Peter H. Jones
Modified: 2013-12-02 07:13 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-02 07:13:25 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (689 bytes, text/plain)
2013-08-13 22:40 EDT, Peter H. Jones
no flags Details
File: core_backtrace (316 bytes, text/plain)
2013-08-13 22:40 EDT, Peter H. Jones
no flags Details
File: environ (1.41 KB, text/plain)
2013-08-13 22:41 EDT, Peter H. Jones
no flags Details
log file requested (22.08 KB, text/plain)
2013-12-01 08:23 EST, Peter H. Jones
no flags Details

  None (edit)
Description Peter H. Jones 2013-08-13 22:40:45 EDT
Description of problem:
Setting extended information box in available networks display screen.

Version-Release number of selected component:
hplip-3.13.7-1.fc18

Additional info:
reporter:       libreport-2.1.5
cmdline:        /usr/bin/python /bin/hp-wificonfig -d hp:/usb/Deskjet_3510_series?serial=CN3251NH8405R7
dso_list:       hplip-gui-3.13.7-1.fc18.x86_64
executable:     /bin/hp-wificonfig
kernel:         3.10.4-100.fc18.x86_64
runlevel:       N 5
uid:            1000

Truncated backtrace:
wifi.py:628:getLocation:UnicodeDecodeError: 'ascii' codec can't decode byte 0xac in position 0: ordinal not in range(128)

Traceback (most recent call last):
  File "/usr/share/hplip/ui4/wifisetupdialog.py", line 347, in ShowExtendedCheckBox_clicked
    self.loadNetworksTable()
  File "/usr/share/hplip/ui4/wifisetupdialog.py", line 377, in loadNetworksTable
    location = wifi.getLocation(bssid, ss)
  File "/usr/share/hplip/base/wifi.py", line 628, in getLocation
    </LocationRQ>""" % (bssid.encode("utf-8"), ss)
UnicodeDecodeError: 'ascii' codec can't decode byte 0xac in position 0: ordinal not in range(128)

Local variables in innermost frame:
ss: 5
bssid: '\xac\xf1\xdfc\x9b\\'
Comment 1 Peter H. Jones 2013-08-13 22:40:50 EDT
Created attachment 786389 [details]
File: backtrace
Comment 2 Peter H. Jones 2013-08-13 22:40:55 EDT
Created attachment 786390 [details]
File: core_backtrace
Comment 3 Peter H. Jones 2013-08-13 22:41:01 EDT
Created attachment 786391 [details]
File: environ
Comment 4 Jiri Popelka 2013-08-16 12:24:23 EDT
Similar to bug #915067, needs more investigation.
Comment 5 Tim Waugh 2013-11-25 11:39:09 EST
Are you able to reproduce the problem or did it happen only once?

Please run:

hp-wificonfig -g &>log.txt

then attach (using the 'Add an attachment' link above) log.txt file to this bug report.
Comment 6 Peter H. Jones 2013-12-01 08:23:25 EST
Created attachment 831209 [details]
log file requested

Now running hplip-3.13.9-2.fc18.x86_64.

I had to plug in the printer with a USB cable when I ran the
command. Also, I had to give the WIFI password. I went through the
configuration process without a problem.

The problem seems to have ocurred only once.
Comment 7 Tim Waugh 2013-12-02 07:13:25 EST
Thanks. There's nothing clearly wrong in the debug output, so it's hard to say what the cause might be.

If you see this happen again, please re-open the bug report.

Note You need to log in before you can comment on or make changes to this bug.