Bug 996840 - The display format of "nodedev-reattach" should be improved in the man help
The display format of "nodedev-reattach" should be improved in the man help
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: libvirt (Show other bugs)
6.5
Unspecified Unspecified
medium Severity medium
: rc
: ---
Assigned To: Martin Kletzander
Virtualization Bugs
: Upstream
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-14 02:24 EDT by Xuesong Zhang
Modified: 2016-04-26 10:04 EDT (History)
5 users (show)

See Also:
Fixed In Version: libvirt-0.10.2-31.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-10-14 00:16:41 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Xuesong Zhang 2013-08-14 02:24:31 EDT
Description of problem:
The display format of "nodedev-reattach" should be improved in the man help.

Version-Release number of selected component (if applicable):
libvirt-0.10.2-21.el6.x86_64
qemu-kvm-0.12.1.2-2.386.el6.x86_64
kernel-2.6.32-411.el6.x86_64

How reproducible:
100%

Steps:
1. #man virsh
2. search the "nodedev-reattach", it is displayed like the following one: "=item nodedev-reattach nodedev". The display format should be improved of "nodedev-reattach" command.
......
       nodedev-list cap --tree
           List all of the devices available on the node that are known by libvirt.  cap is used to
           filter the list by capability types, the types must be separated by comma, e.g. --cap
           pci,scsi, valid capability types include ’system’, ’pci’, ’usb_device’, ’usb’, ’net’,
           ’scsi_host’, ’scsi_target’, ’scsi’, ’storage’. If --tree is used, the output is formatted
           in a tree representing parents of each node. cap and --tree are mutually exclusive.
           =item nodedev-reattach nodedev

           Declare that nodedev is no longer in use by any guests, and that the host can resume
           normal use of the device.  This is done automatically for devices in managed mode, but
           must be done explicitly to match any explicit nodedev-detach.

       nodedev-reset nodedev
           Trigger a device reset for nodedev, useful prior to transferring a node device between
           guest passthrough or the host.  Libvirt will often do this action implicitly when
           required, but this command allows an explicit reset when needed.
......
3. find one rhel7 host, do the step 1 and 2 on the rhel7. The "nodedev-reattach" command format is displayed normally.
......
       nodedev-list cap --tree
           List all of the devices available on the node that are known by libvirt.  cap is used to filter
           the list by capability types, the types must be separated by comma, e.g. --cap pci,scsi, valid
           capability types include 'system', 'pci', 'usb_device', 'usb', 'net', 'scsi_host', 'scsi_target',
           'scsi', 'storage', 'fc_host', 'vports', 'scsi_generic'. If --tree is used, the output is formatted
           in a tree representing parents of each node.  cap and --tree are mutually exclusive.

       nodedev-reattach nodedev
           Declare that nodedev is no longer in use by any guests, and that the host can resume normal use of
           the device.  This is done automatically for devices in managed mode, but must be done explicitly
           to match any explicit nodedev-detach.

       nodedev-reset nodedev
           Trigger a device reset for nodedev, useful prior to transferring a node device between guest
           passthrough or the host.  Libvirt will often do this action implicitly when required, but this
           command allows an explicit reset when needed.
......


Actual results:
In step 2, it is rhel6.5, the display format of command "nodedev-reattach" is wrong.

Expected results:
In step 2, it is rhel6.5, the display format of command "nodedev-reattach" should be same with the one in step 3.

Addtional info:
Comment 3 Martin Kletzander 2014-04-01 04:42:14 EDT
Upstream doesn not have this issue since v1.0.3-158-g652a2ec:

commit 652a2ec63051f1c4570f49858db445b686abbb0e
Author: Osier Yang <jyang@redhat.com>
Date:   Tue Jan 8 01:05:28 2013 +0800

    nodedev: Introduce two new flags for listAll API
Comment 7 Xuesong Zhang 2014-04-14 05:10:19 EDT
Verify with the following package:
libvirt-0.10.2-32.el6.x86_64

Steps:
1. check the virsh command of manual.
# man virsh

2. search "nodedev-reattach" in the manual, the display is well now.
......
       nodedev-reattach nodedev
           Declare that nodedev is no longer in use by any guests, and that
           the host can resume normal use of the device.  This is done
           automatically for devices in managed mode, but must be done
           explicitly to match any explicit nodedev-detach.

       nodedev-reset nodedev
           Trigger a device reset for nodedev, useful prior to transferring a
           node device between guest passthrough or the host.  Libvirt will
           often do this action implicitly when required, but this command
           allows an explicit reset when needed.
......


The result is as expected, so change the status to verified.
Comment 9 errata-xmlrpc 2014-10-14 00:16:41 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-1374.html

Note You need to log in before you can comment on or make changes to this bug.