Bug 996887 - Notification email on task escalation misses last character
Notification email on task escalation misses last character
Status: CLOSED NOTABUG
Product: JBoss BPMS Platform 6
Classification: JBoss
Component: Business Central (Show other bugs)
6.0.0
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Marco Rietveld
Radovan Synek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-14 04:46 EDT by Radovan Synek
Modified: 2016-09-20 01:04 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-04 09:20:26 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
escalation process definition (13.96 KB, application/xml)
2013-08-14 04:46 EDT, Radovan Synek
no flags Details

  None (edit)
Description Radovan Synek 2013-08-14 04:46:17 EDT
Created attachment 786457 [details]
escalation process definition

Description of problem:
Having a simple HT scenario (see an attachment) with defined notification & reassignment deployed & started in Business Central. After specified timeout email has been sent as configured in the notification property of task, but the email was missing the last character. The text is passed to process instance as parameter - with value "Escalation text". But the email I received contained body: "Escalation tex".
I have been using both GreenMail and Wiser libraries for email testing, so I guess there cannot be the same bug in both of them.


Version-Release number of selected component (if applicable):
community 6.0.0.CR1
Comment 1 Marco Rietveld 2013-08-23 10:23:42 EDT
Radovan and Maciej have established that this problem only happens via REST, and not via the UI, which is why I'm now investigating this problem.
Comment 2 Marco Rietveld 2013-08-23 11:02:42 EDT
Kris has categorized this as a low-priority bug. I'm stopping any work on it and probably won't get back to it for at least a week.
Comment 3 Radovan Synek 2013-08-23 11:16:45 EDT
tested with 6.0.0.ER1 again and the behaviour is different than in community 6.0.0.CR1 - whole content of the escalation email's body is missing.
Comment 4 Marco Rietveld 2013-08-29 16:41:00 EDT
Please retest this with ER3: there's info that indicates this problem may no longer exist with the ER3 release.
Comment 5 Radovan Synek 2013-10-01 05:13:47 EDT
Hi Marco,
indeed, this issue is not present in ER3 build. I am able to receive full email (I tried to start the process both via UI and REST)
Comment 6 Marco Rietveld 2013-10-04 09:20:26 EDT
Thanks, Radovan!

Setting this to CLOSED/NOTABUG since Radovan has confirmed that it works in ER3.

Note You need to log in before you can comment on or make changes to this bug.