Bug 996906 - [rhevm-UI] edit storage domain dialog takes about 20 seconds to load
[rhevm-UI] edit storage domain dialog takes about 20 seconds to load
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine (Show other bugs)
3.3.0
x86_64 Linux
unspecified Severity low
: ---
: 3.5.0
Assigned To: Daniel Erez
Aharon Canan
storage
: Triaged
: 996116 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-14 05:21 EDT by sefi litmanovich
Modified: 2016-02-10 12:17 EST (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-11 09:25:14 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Storage
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
engine log (1017.56 KB, text/x-log)
2013-09-01 06:52 EDT, sefi litmanovich
no flags Details
vdsm log (11.14 MB, text/x-log)
2013-09-01 06:54 EDT, sefi litmanovich
no flags Details
supervdsm log (14.93 MB, text/x-log)
2013-09-01 06:56 EDT, sefi litmanovich
no flags Details
screenshot (2.55 MB, image/png)
2013-09-01 06:58 EDT, sefi litmanovich
no flags Details

  None (edit)
Description sefi litmanovich 2013-08-14 05:21:41 EDT
Description of problem:

when opening a new Domain or editing an existing one, the pop-up window takes around 20 seconds to load.

Version-Release number of selected component (if applicable):
is9.1

How reproducible:
always

Steps to Reproduce:
1.in rhevm UI open storage tab.
2.click on New Domain
3.if you have an existing Domain click edit in the menu or right click the Domain and choose eidt

Actual results:

Pop up window loads after 20 seconds

Expected results:

Pop up window load immediately

Additional info:
Comment 1 Mike Burns 2013-08-15 10:40:50 EDT
not sure if backend is right or not, but it's not rhev-h
Comment 2 Sergey Gotliv 2013-08-20 01:14:53 EDT
Please, attach a screenshot of the popup window so I can see which DC(ISCSI, NFS ....) appears first and logs of vdsm and engine. 
I suspect that this is ISCSI and most probably getDeviceList takes so long, screenshot and logs will help.
Comment 3 Sergey Gotliv 2013-08-20 03:55:40 EDT
Please, see comment 2
Comment 4 Alissa 2013-08-21 05:54:58 EDT
Sergey, please see bz996116 - looks like they are duplicates...?
Comment 5 Sergey Gotliv 2013-08-21 06:30:42 EDT
*** Bug 996116 has been marked as a duplicate of this bug. ***
Comment 6 Sergey Gotliv 2013-08-21 06:32:10 EDT
(In reply to Alissa from comment #4)
> Sergey, please see bz996116 - looks like they are duplicates...?
I closed bz996116 as duplicate to this bug
Comment 8 sefi litmanovich 2013-09-01 06:52:57 EDT
Created attachment 792573 [details]
engine log
Comment 9 sefi litmanovich 2013-09-01 06:54:20 EDT
Created attachment 792574 [details]
vdsm log
Comment 10 sefi litmanovich 2013-09-01 06:56:00 EDT
Created attachment 792575 [details]
supervdsm log
Comment 11 sefi litmanovich 2013-09-01 06:58:46 EDT
Created attachment 792576 [details]
screenshot
Comment 12 sefi litmanovich 2013-09-01 06:59:55 EDT
uploaded relevant logs.
this bugs is similar to https://bugzilla.redhat.com/show_bug.cgi?id=996116#c10.
the problem occures only when trying to edit iscsi stroage domain.
currently it takes 'only' 7 seconds to load.
Comment 13 Sergey Gotliv 2014-02-16 02:04:04 EST
Should be tested on RHEL 7.0
Comment 14 Daniel Erez 2014-06-11 09:25:14 EDT
Edit dialog of an active storage domain is being used for VG extending. Hence, by design, when editing a block storage domain, getDeviceList is being invoked in order to get a refreshed list of LUNs. The duration of the operation mainly depends on the underlined storage (i.e. network/storage latency, number of LUNs/targets, env structure, etc).

Note You need to log in before you can comment on or make changes to this bug.